Bug 1347745 - Terminating osp instance outside of cfme results in error
Summary: Terminating osp instance outside of cfme results in error
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Tzu-Mainn Chen
QA Contact: Ola Pavlenko
URL:
Whiteboard: openstack
Depends On:
Blocks: 1353204
TreeView+ depends on / blocked
 
Reported: 2016-06-17 14:06 UTC by Matouš Mojžíš
Modified: 2017-12-05 15:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1353204 (view as bug list)
Environment:
Last Closed: 2016-11-14 12:05:43 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)

Description Matouš Mojžíš 2016-06-17 14:06:38 UTC
Description of problem:


Version-Release number of selected component (if applicable):
5.6.0.11

How reproducible:
Always

Steps to Reproduce:
1. Add an openstack provider
2. Provision VM
3. Terminate VM outside of CFME(in OpenStack Dashboard)

Actual results:
[----] E, [2016-06-17T10:03:54.948161 #2976:bd798c] ERROR -- : Q-task_id([miq_provision_1]) MIQ(MiqQueue#deliver) Message id: [579], Error: [undefined method `state' for nil:NilClass]
[----] E, [2016-06-17T10:03:54.948495 #2976:bd798c] ERROR -- : Q-task_id([miq_provision_1]) [NoMethodError]: undefined method `state' for nil:NilClass  Method:[rescue in deliver]
[----] E, [2016-06-17T10:03:54.948683 #2976:bd798c] ERROR -- : Q-task_id([miq_provision_1]) /var/www/miq/vmdb/app/models/manageiq/providers/openstack/cloud_manager/provision/cloning.rb:5:in `block in do_clone_task_check'


Expected results:
No Error

Additional info:

Comment 3 Dave Johnson 2016-07-06 13:48:48 UTC
Marking as blocker for 5.6.1

Comment 4 Scott Seago 2016-07-13 21:30:04 UTC
So it looks like we can't make the error go away -- we don't support users deleting VMs outside CFME while provisioning is happening, but we should probably check for nil there and report a clearer error message "VM no longer exists" or something like that instead of choking on the nil. Since it's just an error message problem, it seems like this is probably not a blocker (and might need a lower priority).

Comment 8 Matouš Mojžíš 2016-11-14 12:05:43 UTC
Closing as worksforme. I tried to duplicate it many times, but I was unable to.


Note You need to log in before you can comment on or make changes to this bug.