This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 134779 - Acecad input module does not work
Acecad input module does not work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
http://bugzilla.atrpms.net/show_bug.c...
: Triaged
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2004-10-06 05:20 EDT by Stefan Ekman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 04:32:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages (68.98 KB, text/plain)
2004-10-06 12:16 EDT, Stefan Ekman
no flags Details
lsmod > lsmod (1.37 KB, text/plain)
2004-10-06 12:18 EDT, Stefan Ekman
no flags Details
xorg.conf (4.07 KB, text/plain)
2004-10-06 12:18 EDT, Stefan Ekman
no flags Details
Xorg.0.log (43.32 KB, text/plain)
2004-10-06 12:19 EDT, Stefan Ekman
no flags Details

  None (edit)
Description Stefan Ekman 2004-10-06 05:20:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

The acecad tablet is an USB-device used as pointer in X especially for
drawing (in gimp etc).

Description of problem:
According to my log, xorg was build under RHEL3 (2.4.21-14.ELsmp). As
it is compiled under a 2.4 kernel the Xorg.0.log is filled with event
code 0, EV_SYN, which does not exist in 2.4, and
obviously the acecad module for 2.4 kernels does not understand this.

This problem will also occur with other devices using EV_SYN.

Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-9

How reproducible:
Always

Steps to Reproduce:
1. Install a kernel with acecad driver
(http://atrpms.net/dist/fc2/kernel-experimental/)
2. Configure Xorg
Section "ServerLayout"
Identifier "Server Layout"
...
InputDevice "Tablet" "SendCoreEvents"
...
EndSection

Section "InputDevice"
    Identifier  "Tablet"
    Option     "Device"        "auto-dev"
    Driver      "acecad"
EndSection

3. Plug in tablet
4. Restart X
5. Move tablet

    

Actual Results:  Nothing happends when moving pen. Errors about Event
0 in log.

Expected Results:  Pointer movement.

Additional info:

Drivers can be built with this sources instead if you don't want to
use the atrpm provided:

http://perso.wanadoo.fr/septieme/acecad/xfree.html

When using the Xfree driver from the above site it works like a charm.
Comment 1 Mike A. Harris 2004-10-06 09:17:30 EDT
Please make sure you are using an official Red Hat compiled and
built kernel.  Once you have confirmed you are booted into
a Red Hat built kernel, the acecad module should work properly.

If you still have problems with the acecad module while using
the Red Hat kernel, please attach your X server config file,
X server log file, /var/log/messages from boot time onward,
and the output of "lsmod" to the report as individual
uncompressed file attachments.

Comment 2 Stefan Ekman 2004-10-06 12:16:49 EDT
Created attachment 104842 [details]
messages
Comment 3 Stefan Ekman 2004-10-06 12:17:30 EDT
The current Fedora Core 2 kernel from
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/2/i386/
is kernel-2.6.8-1.521.i686.rpm. This does not include the acecad
module, so booting from a redhat compiled kernel is really not an
option, but here are the files requested.
Comment 4 Stefan Ekman 2004-10-06 12:18:10 EDT
Created attachment 104843 [details]
lsmod > lsmod
Comment 5 Stefan Ekman 2004-10-06 12:18:55 EDT
Created attachment 104844 [details]
xorg.conf
Comment 6 Stefan Ekman 2004-10-06 12:19:42 EDT
Created attachment 104845 [details]
Xorg.0.log
Comment 10 Mike A. Harris 2005-04-05 13:58:25 EDT
I've re-reviewed this bug report and it seems this problem only occurs when
you are using a completely unsupported 3rd party kernel.  If our kernel
does not have the functionality required for the acecad module to work,
you can file a feature request against the kernel to request that it
get added if you like.

Alternatively, if the X supplied acecad module is useless without the
3rd party kernel driver, then we will remove the acecad module, as it
has a dependancy on external kernel stuff that we do not currently ship
or support.

Does the "acecad" X driver work at all in any way with our STOCK kernel
unmodified?
Comment 11 Mike A. Harris 2005-04-11 04:32:18 EDT
Closing bug due to lack of feedback.  If the problem occurs again, discuss
it on the xorg@freedesktop.org mailing list and/or report it as a bug
in the X.org official bugzilla at http://bugs.freedesktop.org.


Note You need to log in before you can comment on or make changes to this bug.