Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1347795 - hosts selection list is not sorted
Summary: hosts selection list is not sorted
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3
Assignee: sankarshan
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-17 16:27 UTC by Martin Kudlej
Modified: 2017-03-23 04:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 04:10:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
first order (39.49 KB, image/png)
2016-06-17 16:31 UTC, Martin Kudlej
no flags Details
second order (38.45 KB, image/png)
2016-06-17 16:31 UTC, Martin Kudlej
no flags Details

Description Martin Kudlej 2016-06-17 16:27:29 UTC
Description of problem:
It is hard to iterated over all hosts in host list because it is different every time user opens it. It should be sorted.

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-20.el7scon.noarch
ceph-installer-1.0.12-2.el7scon.noarch
rhscon-ceph-0.0.23-1.el7scon.x86_64
rhscon-core-0.0.24-1.el7scon.x86_64
rhscon-ui-0.0.39-1.el7scon.noarch

How reproducible:
100%

Steps to Reproduce:
1. accept some hosts
2. got to hosts/_host_id_
3. try to select different host by clicking on end of breadcrumb

Actual results:
List has random order.

Expected results:
List will be sorted so user can easily iterate in it.

Comment 1 Martin Kudlej 2016-06-17 16:31:25 UTC
Created attachment 1169174 [details]
first order

Comment 2 Martin Kudlej 2016-06-17 16:31:50 UTC
Created attachment 1169175 [details]
second order


Note You need to log in before you can comment on or make changes to this bug.