Bug 1347844 - Mis-aligned fields in Pools list
Summary: Mis-aligned fields in Pools list
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: Martin Kudlej
URL:
Whiteboard:
Depends On:
Blocks: Console-2-GA
TreeView+ depends on / blocked
 
Reported: 2016-06-17 20:16 UTC by Matt Carrano
Modified: 2016-08-23 19:55 UTC (History)
5 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:55:37 UTC
Target Upstream Version:


Attachments (Terms of Use)
Current list view (60.96 KB, image/png)
2016-06-17 20:16 UTC, Matt Carrano
no flags Details
Alternative design with simplified chart (86.62 KB, image/png)
2016-06-17 20:17 UTC, Matt Carrano
no flags Details
wrong layout (27.36 KB, image/png)
2016-07-22 13:23 UTC, Martin Kudlej
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 0 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Matt Carrano 2016-06-17 20:16:43 UTC
Created attachment 1169212 [details]
Current list view

Description of problem:
Still seeing mis-aligned fields in the Pools list view (see screen shot).  This causes an uneven effect as you read down the columns.  Eliminating the text that stacks vertically to the right of the donut chart may help.  Recommend making this more like in the Hosts view with the % in the center and a simple text label below the donut.  The user can get details by hovering on the donut chart.  See attachment for how this might look.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.Go to Storage-Pools page
2.
3.

Actual results:
Uneven columns as in the screen shot

Expected results:
Consistently spacing and formatting between list entries.

Additional info:

Comment 2 Matt Carrano 2016-06-17 20:17:47 UTC
Created attachment 1169213 [details]
Alternative design with simplified chart

Comment 3 Martin Kudlej 2016-07-22 13:22:32 UTC
I still see this issue ceph-ansible-1.0.5-27.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ui-0.0.48-1.el7scon.noarch

Comment 4 Martin Kudlej 2016-07-22 13:23:45 UTC
Created attachment 1182852 [details]
wrong layout

Comment 6 Martin Kudlej 2016-07-29 13:42:27 UTC
Tested with
ceph-ansible-1.0.5-31.el7scon.noarch
ceph-installer-1.0.14-1.el7scon.noarch
rhscon-ceph-0.0.38-1.el7scon.x86_64
rhscon-core-0.0.38-1.el7scon.x86_64
rhscon-core-selinux-0.0.38-1.el7scon.noarch
rhscon-ui-0.0.51-1.el7scon.noarch
and it works.

Comment 8 errata-xmlrpc 2016-08-23 19:55:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.