Bug 1347902 - http_proxy settings not saved when blank
Summary: http_proxy settings not saved when blank
Status: CLOSED DUPLICATE of bug 1358448
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
(Show other bugs)
Version: 5.8.0
Hardware: Unspecified Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Jason Frey
QA Contact: Jeff Teehan
URL:
Whiteboard: proxy
Keywords: Reopened, ZStream
Depends On:
Blocks: 1353301
TreeView+ depends on / blocked
 
Reported: 2016-06-18 03:09 UTC by David La Motta
Modified: 2017-10-05 15:12 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1353301 (view as bug list)
Environment:
Last Closed: 2017-10-05 15:12:23 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

Description David La Motta 2016-06-18 03:09:31 UTC
Description of problem:
The http_proxy host and port values cannot be cleared. 


Version-Release number of selected component (if applicable):
5.6.0.9-rc2.20160531154046_b4e2f6d


How reproducible:
100% of the time


Steps to Reproduce:
1. Start with no http_proxy host and port
2. Enter some values for the http_proxy host and port
3. Click Save and verify the values are there
4. You may restart the evmserverd.service if you want to be thorough
5. Now clear the values for host and port in the http_proxy section
6. Click Save and you'll see the old values are still there
7. Restart evmserverd.service to see if by any chance a restart clears the values
8. Verify the old values are still there

9. Bonus steps, instead of clearing the values, enter new ones
10. Click save and verify those values are persisted
11. Restart the evmserverd.service and anything but the empty values are there

Actual results:


Expected results:


Additional info:

Comment 3 Jeff Teehan 2016-06-20 04:50:07 UTC
I got it.  This is mine to follow up with.

Comment 4 Jared Deubel 2016-06-20 19:10:34 UTC
As a workaround please navigate in the Postgresql server to the settings_changes table and look for:

Snippet from settings_changes table:
=============================================================
/http_proxy/host";"--- proxy.usersys.redhat.com
/http_proxy/password";"--- v2:{5Gk+4UfTm/otsP4udumcRQ==}  <----fake password
/http_proxy/port";"--- 9090
=============================================================

Remove the following or edit it depending on what is needed. If you remove the three rows you will need to restart CFME to clear the cache.

Comment 7 Krain Arnold 2017-06-15 11:47:06 UTC
Any update on this? this is still an issue in 4.5.

Comment 8 Chris Pelland 2017-08-28 14:46:04 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 
If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Comment 9 Krain Arnold 2017-08-28 18:20:33 UTC
still applicable in 5.8

Comment 10 Jason Frey 2017-10-05 15:12:23 UTC

*** This bug has been marked as a duplicate of bug 1358448 ***


Note You need to log in before you can comment on or make changes to this bug.