Bug 1347928 - Frontpage exposes runtime error with no cookies enabled in browser
Summary: Frontpage exposes runtime error with no cookies enabled in browser
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Varun Mylaraiah
QA Contact: Kaleem
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-18 14:14 UTC by Andre Klapper
Modified: 2016-11-04 05:55 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:55:12 UTC


Attachments (Terms of Use)
verification screenshot (46.68 KB, image/png)
2016-09-13 10:48 UTC, Varun Mylaraiah
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC
GNOME Bugzilla 767790 None None None 2016-06-18 14:14 UTC

Description Andre Klapper 2016-06-18 14:14:40 UTC
STEPS TO REPRODUCE:

Go to https://account.gnome.org/ipa/ui/ without having cookies allowed for https://account.gnome.org/

EXPECTED OUTCOME:

A message telling me to enable cookies and try again.

ACTUAL OUTCOME:

Runtime error

Web UI got in unrecoverable state during "init" phase
Technical details:
The operation is insecure.
.cache["freeipa/app_container"]/</<.register_phases/<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:427
.cache["dojo/_base/lang"]/</a.hitch/<@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:26299
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase/<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3163
.cache["dojo/_base/array"]/</a.forEach@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:29752
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3127
.cache["freeipa/_base/Phase_controller"]/</u<.next_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3589
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase/<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3326
.cache["dojo/_base/lang"]/</a.hitch/<@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:26299
.cache["dojo/Deferred"]/</c@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60960
.cache["dojo/Deferred"]/</d/t.then@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:62246
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3235
.cache["freeipa/_base/Phase_controller"]/</u<.next_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3589
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase/<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3326
.cache["dojo/_base/lang"]/</a.hitch/<@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:26299
.cache["dojo/Deferred"]/</c@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60960
.cache["dojo/Deferred"]/</d/t.then@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:62246
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3235
.cache["freeipa/_base/Phase_controller"]/</u<.next_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3589
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase/<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3326
.cache["dojo/_base/lang"]/</a.hitch/<@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:26299
.cache["dojo/Deferred"]/</c@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60960
.cache["dojo/Deferred"]/</d/t.then@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:62246
.cache["freeipa/_base/Phase_controller"]/</u<._run_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3235
.cache["freeipa/_base/Phase_controller"]/</u<.next_phase@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:3589
.cache["freeipa/_base/Phase_controller"]/</u<.run@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:2939
.cache["freeipa/app_container"]/</<.run/<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:1411
.cache["dojo/_base/lang"]/</a.hitch/<@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:26299
.cache["dojo/Deferred"]/</c@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60960
.cache["dojo/Deferred"]/</l@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60886
.cache["dojo/Deferred"]/</d/this.resolve@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:61873
.cache["freeipa/plugin_loader"]/</i.load_plugins/</<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:2166
.cache["dojo/Deferred"]/</c@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60960
.cache["dojo/Deferred"]/</l@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60886
.cache["dojo/Deferred"]/</d/this.resolve@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:61873
.cache["dojo/promise/all"]/</</</<@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:85255
.cache["dojo/Deferred"]/</c@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60960
.cache["dojo/Deferred"]/</l@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:60886
.cache["dojo/Deferred"]/</d/this.resolve@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:61873
.cache["freeipa/plugin_loader"]/</i.load_plugin/<@https://account.gnome.org/ipa/ui/js/freeipa/app.js?40200:1:1920
Vt@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:7727
Zt@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:8900
nn/<@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:9086
tn@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:8962
nn@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:9026
ln/i@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:10124
p.injectUrl/i@https://account.gnome.org/ipa/ui/js/dojo/dojo.js?v=40200:1:12307

Comment 2 Petr Vobornik 2016-06-19 17:56:05 UTC
Was fixed upstream in #4338

master:

https://fedorahosted.org/freeipa/changeset/3c519951c5a719421d5abfa864dfeb6fbce6869d/ webui: fail nicely if cookies are disabled

It now shows:

"""
Runtime error
Web UI got in unrecoverable state during "init" phase.

Technical details:

Web UI requires cookies enabled. Possible cause: too strict browser configuration.
"""

Comment 3 Petr Vobornik 2016-06-19 17:56:47 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/4338

Comment 5 Varun Mylaraiah 2016-09-13 10:48 UTC
Created attachment 1200462 [details]
verification screenshot

Verified
on ipa-server version ipa-server-4.4.0-10.el7.x86_64

Yes,

It now shows:

"""
Runtime error
Web UI got in unrecoverable state during "init" phase.

Technical details:

Comment 7 errata-xmlrpc 2016-11-04 05:55:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.