Bug 1347951 - [abrt] gnome-abrt: __init__.py:340:wrapped:TypeError: Argument 1 does not allow None as a value
Summary: [abrt] gnome-abrt: __init__.py:340:wrapped:TypeError: Argument 1 does not all...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-abrt
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Filak
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0c933f81847bf151fa30f20c73f...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-19 00:49 UTC by iliketurtlesbro
Modified: 2016-12-01 00:50 UTC (History)
5 users (show)

Fixed In Version: gnome-abrt-1.2.4-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-29 10:44:13 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (845 bytes, text/plain)
2016-06-19 00:49 UTC, iliketurtlesbro
no flags Details
File: environ (1.47 KB, text/plain)
2016-06-19 00:49 UTC, iliketurtlesbro
no flags Details

Description iliketurtlesbro 2016-06-19 00:49:07 UTC
Description of problem:
Was in the middle of generating a local stacktrace when Problem Reporting apparently crashed/encountered an error.

Version-Release number of selected component:
gnome-abrt-1.2.4-1.fc25

Additional info:
reporter:       libreport-2.7.1
cmdline:        /usr/bin/python3 /usr/bin/gnome-abrt
executable:     /usr/bin/gnome-abrt
kernel:         4.7.0-0.rc3.git3.1.fc25.x86_64
pkg_vendor:     Fedora Project
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
__init__.py:340:wrapped:TypeError: Argument 1 does not allow None as a value

Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/gnome_abrt/views.py", line 1117, in do_box_header_left_size_allocate
    padding = self.get_box_header_left_offset()
  File "/usr/lib64/python3.5/site-packages/gnome_abrt/views.py", line 1089, in get_box_header_left_offset
    offset = box_header_left.translate_coordinates(paned, 0, 0)[0]
  File "/usr/lib64/python3.5/site-packages/gi/overrides/__init__.py", line 340, in wrapped
    ret = method(*args, **kwargs)
TypeError: Argument 1 does not allow None as a value

Local variables in innermost frame:
args: (<Gtk.Box object at 0x7f22ae05cb88 (GtkBox at 0x55f8c672f510)>, None, 0, 0)
method: gi.FunctionInfo(translate_coordinates)
kwargs: {}
fail_ret: None
exc_type: None
exc_str: None

Comment 1 iliketurtlesbro 2016-06-19 00:49:11 UTC
Created attachment 1169453 [details]
File: backtrace

Comment 2 iliketurtlesbro 2016-06-19 00:49:13 UTC
Created attachment 1169454 [details]
File: environ

Comment 3 Rafal Luzynski 2016-06-21 22:57:48 UTC
Thank you for your report, it looks complete. Please answer these questions:

1. How often does this happen: did it happen only once or happens always?
2. Have you been resizing (also: maximizing, minimizing, restoring) the gnome-abrt window when the crash occurred, or have you performed some other action which might have caused the window resize indirectly, like changing the screen resolution, resizing the virtual machine window, tweaking with the GUI shell, running/closing other applications?
3. What is your desktop environment? Looks like GNOME but is it GNOME 2 or 3 or some fork of the above?

Comment 4 Rafal Luzynski 2016-06-29 10:44:13 UTC
Thank you, based on your backtrace we have managed to fix it in this commit:

https://github.com/abrt/gnome-abrt/commit/1424e33


Note You need to log in before you can comment on or make changes to this bug.