Bug 134796 - cannot loging with rsh and telnet: 'system error'
cannot loging with rsh and telnet: 'system error'
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 09:12 EDT by Ben
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-13 11:50:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -f -s 256 -p [pid of xinetd] (220.57 KB, text/plain)
2004-10-06 09:14 EDT, Ben
no flags Details

  None (edit)
Description Ben 2004-10-06 09:12:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002
Firefox/0.10.1

Description of problem:
Previously, telnet and rsh were working fine on my machine, and I
could use either to connect to it.

Now however, any attempt to rlogin to the machine results in the error
message 'System error' followed by 'rlogin: connection closed.'

SSH logins still work fine. telnet logins are even more unpleasant:

[local@hydra local]$ telnet calliope
Trying 10.100.1.215...
Connected to calliope.
Escape character is '^]'.
Fedora Core release 2 (Tettnang)
Kernel 2.6.8.1 on an i686
Login incorrect

Login incorrect

Login incorrect


Login incorrect
Connection closed by foreign host.


I have NIS configured - however, I get the same problem using local
users as well as NIS ones.

I'll attach an strace of xinetd + children during a rlogin



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. set up .rhosts properly
2. login to another machine
3. attempt to login to the affected machine
    

Actual Results:  'System error' message and then connection close

Expected Results:  A shell on the machine

Additional info:
Comment 1 Ben 2004-10-06 09:14:12 EDT
Created attachment 104833 [details]
strace -f -s 256 -p [pid of xinetd]
Comment 3 Marc Minato 2004-10-13 11:29:50 EDT
I was seeing these failures as well.

Seems to be caused by a missing "/etc/pam.d/remote" file.  I copied
"/etc/pam.d/rlogin" to "/etc/pam.d/remote" and my telnet/rlogin
problems disappeared.

This was deduced from the 'strace' output:

3839  open("/etc/pam.d/remote", O_RDONLY) = -1 ENOENT (No such file or
directory)
3839  open("/etc/pam.d/other", O_RDONLY) = 3
Comment 4 Ben 2004-10-13 11:50:58 EDT
Thanks! The workings of pam are a mystery to me...


It seems that util-linux-2.12a-12 now includes a /etc/pam.d/remote
file as well, so this bug has been fixed.

Note You need to log in before you can comment on or make changes to this bug.