Bug 1347974 - UI - Wrong LUN check when editing ISCSI/FC domain
Summary: UI - Wrong LUN check when editing ISCSI/FC domain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.0.1
: 4.0.0
Assignee: Fred Rolland
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-19 13:32 UTC by Fred Rolland
Modified: 2016-07-19 06:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 06:23:54 UTC
oVirt Team: Storage
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
rule-engine: planning_ack+
amureini: devel_ack+
acanan: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 59442 0 master MERGED webadmin: Wrong validation on update SAN SD 2016-06-19 14:55:24 UTC
oVirt gerrit 59446 0 ovirt-engine-4.0 MERGED webadmin: Wrong validation on update SAN SD 2016-06-20 10:50:35 UTC

Description Fred Rolland 2016-06-19 13:32:36 UTC
Description of problem:
When editing a ISCSI/FC domain, a wrong availability check is done on all the LUNs visible to host.
Even if you just edit the name, it will show a wrong warning message saying that the LUNs are already in use.

Version-Release number of selected component (if applicable):
4.0.0

How reproducible:
100%


Steps to Reproduce:
1. "Manage Domain" of an existing SCSI/FC domain.
2. Change the name of the domain and click "OK"

Actual results:
Get a warning message : The following LUNs are already in use:
- 3600140534c4697ad9aa4fcc8ea673855 (Used by VG: 119inv-oze3-96Z3-3XK5-LB3n-MN40-ki90v4)


Expected results:
The SD name is updated


Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2016-06-19 14:16:09 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Kevin Alon Goldblatt 2016-07-14 11:02:48 UTC
Verified with the following code:
---------------------------------------
vdsm-4.18.4-2.el7ev.x86_64
rhevm-4.0.2-0.2.rc1.el7ev.noarch

Verified using the following scenario:
1. "Manage Domain" of an existing SCSI/FC domain.
2. Change the name of the domain and click "OK"

Actual results:
The SD name is updated and no errors are reported!



Moving to VERIFIED!

Comment 3 Sandro Bonazzola 2016-07-19 06:23:54 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/


Note You need to log in before you can comment on or make changes to this bug.