Bug 1347994 - Failure to arrive at graphical login when booting Fedora 24 KDE Live ISO from USB stick
Summary: Failure to arrive at graphical login when booting Fedora 24 KDE Live ISO from...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kwin
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Vrátil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-19 19:28 UTC by Chris Murphy
Modified: 2017-08-08 14:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 14:53:16 UTC
Type: Bug


Attachments (Terms of Use)
photo (1.88 MB, image/jpeg)
2016-06-19 19:29 UTC, Chris Murphy
no flags Details
journal (219.57 KB, text/plain)
2016-06-19 19:31 UTC, Chris Murphy
no flags Details
journal 2 (221.55 KB, text/plain)
2016-06-19 19:56 UTC, Chris Murphy
no flags Details
boot.log (4.51 KB, application/octet-stream)
2016-06-19 19:56 UTC, Chris Murphy
no flags Details
Xorg.0.log (19.28 KB, text/plain)
2016-06-19 19:56 UTC, Chris Murphy
no flags Details
lastlog (285.44 KB, application/octet-stream)
2016-06-19 19:57 UTC, Chris Murphy
no flags Details
messages (162.64 KB, text/plain)
2016-06-19 19:57 UTC, Chris Murphy
no flags Details
lspci (67.55 KB, text/plain)
2016-06-19 19:59 UTC, Chris Murphy
no flags Details

Description Chris Murphy 2016-06-19 19:28:05 UTC
Description of problem:

When booting Fedora-KDE-Live-x86_64-24-1.2.iso imaged to a USB stick, the boot hangs during the text scroll without any error messages or indication why the graphical login isn't appearing.


Version-Release number of selected component (if applicable):
Fedora-KDE-Live-x86_64-24-1.2.iso


How reproducible:
Always, on a Macbook Pro 8,2 (2011)
Never, on the same hardware, with Fedora-Workstation-Live-x86_64-24-1.2.iso.


Steps to Reproduce:
1. Create USB stick using dd (also tried livecd-iso-to-disk with overlay)
2. Tried the default boot option, no joy
3. Tried the basic video boot option, no joy
4. Tried using i915.modeset=0, also no joy

Actual results:

Does not transition from boot text scroll to graphical mode, does not arrive at a graphical login screen or the desktop.


Expected results:

Should arrive at a graphical login screen or maybe the desktop.


Additional info:

Comment 1 Chris Murphy 2016-06-19 19:29:39 UTC
Created attachment 1169589 [details]
photo

Photo showing the point where the boot text scroll stops and hangs indefinitely.

Comment 2 Chris Murphy 2016-06-19 19:31:15 UTC
Created attachment 1169591 [details]
journal

Booted to multi-user.target, enabled ssh, and then rebooted normally, logged in via ssh and captured the journal for this hung boot using 'journalctl -b -o short-monotonic'

Comment 3 Chris Murphy 2016-06-19 19:56:14 UTC
Created attachment 1169594 [details]
journal 2

Replacing the journal with a cleaned up one that doesn't have weird special characters that 'script' apparently can't handle.

Comment 4 Chris Murphy 2016-06-19 19:56:26 UTC
Created attachment 1169595 [details]
boot.log

Comment 5 Chris Murphy 2016-06-19 19:56:41 UTC
Created attachment 1169596 [details]
Xorg.0.log

Comment 6 Chris Murphy 2016-06-19 19:57:05 UTC
Created attachment 1169597 [details]
lastlog

Comment 7 Chris Murphy 2016-06-19 19:57:13 UTC
Created attachment 1169598 [details]
messages

Comment 8 Chris Murphy 2016-06-19 19:59:41 UTC
Created attachment 1169599 [details]
lspci

Comment 9 Chris Murphy 2016-06-19 21:03:50 UTC
OK this looks like some kind of ATI/Radeon bug with kwin-x11. If I disable ATI graphics in GRUB using 
outb 0x728 1
outb 0x710 2
outb 0x740 2
outb 0x750 0
And therefore rely only on i915 graphics, the problem doesn't happen -> I get to the plasma desktop. Over on GNOME I can get to the desktop with either ATI or i915 graphics. The limiting factor is I can't use dual graphics (external display) with i915 on this laptop, it requires discrete GPU for that to work.

Comment 10 Marcel Mol 2016-06-28 14:39:23 UTC
Having a similar issue. I normally boot up in text mode and run 'init 5' as root to get the KDE up and running. However after the upgrade from fedora 23 to 24 nothing happens at that time. I just get the prompt back (also tried systemctl start grpaphical.target but that gives the same reuslt).  There is not logging whatsoever. Clearly X does not start as there is no Xorg.log.

But when I run 'startx' alls seems to be fine (typing this message from the gui now...)

looking at graphical.target it wants display-manager.service. But display-manager.service is not found

Comment 11 Rex Dieter 2016-06-28 14:45:15 UTC
errors on upgrades are tracked elsewhere, see also
if using kdm:
https://bugzilla.redhat.com/show_bug.cgi?id=1337546

otherwise possibly,
https://bugzilla.redhat.com/show_bug.cgi?id=1349664

Comment 12 Rex Dieter 2016-06-28 14:50:48 UTC
Apparently some ati driver issue, though logs don't give much to go on.

Mind trying again, and see if you can capture the contents of ~/.xsession-errors too?

Comment 13 Chris Murphy 2016-06-28 15:47:41 UTC
It looks untouched from when I successfully booted with i915 graphics. If I delete it while in KDE + i915, reboot with ATI enabled and i915 disabled, the file doesn't exist, so for whatever reason it's not even getting far enough to create this file with an ATI active boot.

Is drm.debug=14 going to be helpful here or other? There might be a long standing kernel bug here that affects KDE in a way that doesn't affect GNOME.

Jun 28 09:38:14 f24m kernel: radeon 0000:01:00.0: evergreen_surface_check_2d:281 texture pitch 3648 invalid must be al
Jun 28 09:38:14 f24m kernel: radeon 0000:01:00.0: evergreen_cs_track_validate_texture:830 texture invalid 0x383c71c1 0
Jun 28 09:38:14 f24m kernel: [drm:radeon_cs_ioctl [radeon]] *ERROR* Invalid command stream !

Comment 14 Fedora End Of Life 2017-07-25 21:08:04 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 15 Fedora End Of Life 2017-08-08 14:53:16 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.