Bug 1347999 - RFE: add `+=` config ini syntax to append options
Summary: RFE: add `+=` config ini syntax to append options
Keywords:
Status: CLOSED DUPLICATE of bug 1348766
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 24
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-19 20:18 UTC by Onuralp SEZER
Modified: 2016-07-05 19:22 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-05 19:22:02 UTC
Type: Bug


Attachments (Terms of Use)

Description Onuralp SEZER 2016-06-19 20:18:24 UTC
Description of problem:
OS : Fedora 24
command : dnf update 

Result : 

Dependencies resolved.
Error: The operation would result in removing the booted kernel: kernel-core-4.5.5-300.fc24.x86_64.

It's simply trying to remove booted and I have 2 kernels 

# rpm -q  kernel
kernel-4.5.2-302.fc24.x86_64
kernel-4.5.5-300.fc24.x86_64

My dnf conf is 

[root@localhost dnf]# cat dnf.conf 

[main]
gpgcheck=1
installonly_limit=4
clean_requirements_on_remove=True
installonlypkgs=electron

Version-Release number of selected component (if applicable):

dnf-1.1.9-2.fc24.noarch


How reproducible:
dnf update

Steps to Reproduce:
1. dnf update and warning message

Actual results:
Cancel the update because of kernel update problem. I can skip that If I exclude kernel and continue the update other packages but not the kernel but If install myself manually It will going to install new kernel and then we can updated but never did. 

Expected results:
Update system normally 

Additional info:
If need let me know


Thank you

Comment 1 Honza Silhan 2016-06-20 11:47:49 UTC
The problem is that the specified option in conf overridden the default value. We can introduce the new syntax that would append the new ones to existing value.

Comment 2 Michael Mráka 2016-06-20 12:17:03 UTC
To make it clear:
You've specified
  installonlypkgs=electron
in dnf.conf which replaces default instalonlypkgs value.
If you want to add electron to the list of installonly packages you have to include old values as well:
  installonlypkgs=kernel installonlypkg(kernel) installonlypkg(kernel-module) installonlypkg(vm) electron

Comment 3 Onuralp SEZER 2016-06-21 02:16:11 UTC
I changed that value and now I can install kernel and others too or just simply disable also works too 

thank you.

Comment 4 Honza Silhan 2016-06-27 11:20:29 UTC
we can also don;t override the default value "kernel". We should just unify all ~kernel provides to one kernel provide name and abandon "installonlypkg(*)"

Comment 5 Igor Gnatenko 2016-07-05 19:22:02 UTC

*** This bug has been marked as a duplicate of bug 1348766 ***


Note You need to log in before you can comment on or make changes to this bug.