Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1348058 - dashboard doesn't load in firefox < 43
Summary: dashboard doesn't load in firefox < 43
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine-dashboard
Classification: oVirt
Component: Core
Version: unspecified
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Greg Sheremeta
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 04:38 UTC by mxie@redhat.com
Modified: 2016-07-03 16:56 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-03 16:56:52 UTC
oVirt Team: UX
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
screenshot (72.63 KB, image/png)
2016-06-20 04:38 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2016-06-20 04:38:02 UTC
Created attachment 1169647 [details]
screenshot

Description of problem:
Should give a reminder about update firefox version on rhevm4.0 if firefox version is too low to load hardware info in dashboard


Version-Release number of selected component (if applicable):
RHEVM:4.0.0.4-0.1.el7ev
firefox-38.1.0-1.el6_6.x86_64
firefox-38.3.0-2.el7_1.x86_64


How reproducible:
100%

Steps to Reproduce:
1 Login rhevm4.0 by FQDN: https://ibm-x3250m5-03.rhts.eng.pek2.redhat.com/ovirt-engine/
2.Click dashboard option, it always shows loading even if waiting for a long time,pls refer to screenshot
3.Update firefox to below version, then rhevm4.0 could load the hardware info in dashboard normally
firefox-45.1.1-1.el7_2.x86_64
firefox-45.0.1-1.el6.x86_64


Actual results:
As above description

Expected results:
Should give a reminder about update firefox version on rhevm4.0 if firefox version is too low to load hardware info in dashboard
 

Additional info:

Comment 1 Oved Ourfali 2016-06-22 14:11:58 UTC
Greg - we recently changed the "error" message we give when loading.
Any ideas here?

Comment 2 Greg Sheremeta 2016-06-22 14:15:25 UTC
We removed the message because we should support everything in all modern browsers.

In this case, FF 38 is relatively new, and is an ESR, so I would consider this a dashboard bug.

Comment 3 Oved Ourfali 2016-06-22 14:24:18 UTC
Okay.
Changed accordingly.
Let's check if the latest fixes help with that at all and continue from there.

Comment 6 Red Hat Bugzilla Rules Engine 2016-06-23 00:06:04 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 7 Greg Sheremeta 2016-07-03 16:41:08 UTC
The root cause is that we're using a relatively new feature, Array.includes(), in our own code. According to mozilla.org [1], this feature was introduced only in Firefox 43.

There is a polyfill npm module available called array-includes. I gave it a quick try and it didn't fix the issue. I might mess with it a bit more, or I might just replace it with Array.indexOf() :)

[1] https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Global_Objects/Array/includes

Comment 8 Oved Ourfali 2016-07-03 16:56:52 UTC
We aren't fixing this. It was also raised in other bugs. Closing. Thanks Greg for digging into that.


Note You need to log in before you can comment on or make changes to this bug.