Bug 1348066 - [CockPit] - The default bonding mode should be safe defaults - mode 4 - Dynamic link aggregation(802.3ad) or mode 1 - active-backup
Summary: [CockPit] - The default bonding mode should be safe defaults - mode 4 - Dynam...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit
Version: 7.2
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Dominik Perpeet
QA Contact: Jan Ščotka
URL:
Whiteboard:
Keywords: Extras
Depends On:
Blocks: node-cockpit ovirt-node-ng-platform
TreeView+ depends on / blocked
 
Reported: 2016-06-20 05:16 UTC by Michael Burman
Modified: 2016-08-05 09:11 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-08-04 13:48:26 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1442 normal SHIPPED_LIVE cockpit bug fix and enhancement update 2016-08-04 17:45:50 UTC

Description Michael Burman 2016-06-20 05:16:38 UTC
Description of problem:
[CockPit] - The default bonding mode should be safe defaults - mode 4 - Dynamic link aggregation(802.3ad) or mode 1 - active-backup. 

The default bond mode in cockpit is a Round-robin and this should be changed, cause it's not a safe default bonding mode. It can cause to issues, lead to problems with VM networks(add host will fail in rhev-m), problems with hosted-engine setup and this is defiantly not the most used bonding mode. 

The default bonding mode should be mode 4(the default in rhev-m) or active-backup(default in rhev-h). 

Version-Release number of selected component (if applicable):
rhevh7-ng-4.0-0.20160608.0+1

How reproducible:
100 

Steps to Reproduce:
1. Create bond in cockpit

Actual results:
Default bond mode is round-robin.
Add host failed in rhev-m(ovirtmgmt is a VM network and can't be configured over a bond mode 0) 

Expected results:
The default bonding mode should be a safe one - mode 4 or mode 1.

Comment 1 Dominik Perpeet 2016-06-20 13:20:53 UTC
Sounds like a good reason to change this. I believe the initial choice was rather arbitrary.

Comment 2 Fabian Deutsch 2016-06-20 19:46:51 UTC
Btw - I'd go with active-backup, this is the safest approach working with all switches etc.

802.3ad requires switch support.

Comment 3 Andreas Nilsson 2016-07-01 14:17:45 UTC
The initial list order probably came from this order:
https://en.wikipedia.org/wiki/Link_aggregation#Driver_modes

If active-backup is a safer choice I'll trust your word on it.

Comment 4 Andreas Nilsson 2016-07-01 14:20:45 UTC
Another reason might have been that round-robin gives both load balancing and fault tolerance, and that kind of gave you a good outcome if you wasn't super good at what all the modes does.
But we do not want the defaults to result in something that just breaks setups, so I'm good at switching to active-backup.

Comment 5 Stef Walter 2016-07-06 02:40:14 UTC
This will be part of 0.113

https://github.com/cockpit-project/cockpit/pull/4653

Comment 7 Stef Walter 2016-07-14 12:15:25 UTC
No test yet as far as I can tell. A test should be added here:

https://github.com/cockpit-project/cockpit/blob/master/test/verify/check-networking#L191

Comment 11 errata-xmlrpc 2016-08-04 13:48:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1442.html


Note You need to log in before you can comment on or make changes to this bug.