Bug 1348070 - mirror-on-sync option is not set properly during repository create
Summary: mirror-on-sync option is not set properly during repository create
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Peter Ondrejka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 05:32 UTC by Geoff Gatward
Modified: 2019-09-26 16:19 UTC (History)
4 users (show)

Fixed In Version: rubygem-katello-3.0.0.81-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-26 12:26:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 15513 None None None 2016-06-23 20:35:12 UTC
Red Hat Product Errata RHBA-2016:2108 normal SHIPPED_LIVE Satellite 6.2.3 Async Bug Release 2016-10-26 16:21:52 UTC

Description Geoff Gatward 2016-06-20 05:32:07 UTC
Creating a repository with --mirror-on-sync=false results in the repository being created, but 'Mirror on Sync' is actually still set to true.

To reproduce (6.2.0 Beta2)

hammer product create --name='product1' --organization-id=1
hammer repository create \
  --name='testrepo1' \
  --organization-id=1 \
  --product='product1' \
  --content-type='yum' \
  --publish-via-http=false \
  --mirror-on-sync=false \
  --download-policy=immediate


hammer repository info --product='product1' --name='testrepo1'  

(This does not show the state of the Mirror on Sync option)

Login to the WebUI and navigate to the new repo shows  Mirror on Sync = Yes

Comment 1 Brad Buckingham 2016-06-23 20:27:47 UTC
After looking in to this issue, it exists for UI, CLI and API.  Regardless of what the user provides for mirror_on_sync during repository creation, it will default to 'Yes'.  

A workaround for this is to perform an update to the repository after creation, if mirror_on_sync=false is desired.

Comment 2 Brad Buckingham 2016-06-23 20:35:10 UTC
Created redmine issue http://projects.theforeman.org/issues/15513 from this bug

Comment 3 Brad Buckingham 2016-06-23 21:03:18 UTC
Upstream Katello PR: https://github.com/Katello/katello/pull/6149

Comment 5 Bryan Kearney 2016-06-28 20:18:05 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/15513 has been closed

Comment 6 Peter Ondrejka 2016-10-10 10:19:05 UTC
Verified on satellite-6.2.3-1.0, mirror-on-sync setting is accepted for repositories created via cli, ui, api. 

Filed BZ#1383258 for missing entry in hammer repository info.

Comment 8 errata-xmlrpc 2016-10-26 12:26:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2108


Note You need to log in before you can comment on or make changes to this bug.