Bug 1348130 - Ubuntu - /usr/share/ceph-ansible/roles/ceph-agent/tasks/pre_requisite.yml installs calamari-server instead of rhscon-agent
Summary: Ubuntu - /usr/share/ceph-ansible/roles/ceph-agent/tasks/pre_requisite.yml ins...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Alfredo Deza
QA Contact: Daniel Horák
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 08:55 UTC by Daniel Horák
Modified: 2016-08-23 19:55 UTC (History)
9 users (show)

Fixed In Version: ceph-ansible-1.0.5-22.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:55:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Daniel Horák 2016-06-20 08:55:01 UTC
Description of problem:
  Ceph-installer task launched via "/setup/agent/" api call installs calamari-server on Ubuntu instead of rhscon-agent.

Version-Release number of selected component (if applicable):
  ceph-ansible-1.0.5-20.el7scon.noarch

How reproducible:
  100%

Steps to Reproduce:
Check /usr/share/ceph-ansible/roles/ceph-agent/tasks/pre_requisite.yml on ceph-installer server.

Actual results:
# cat /usr/share/ceph-ansible/roles/ceph-agent/tasks/pre_requisite.yml
  - name: install dependencies
  apt:
    pkg: calamari-server
    state: present
  when: ansible_os_family == 'Debian'
  tags:
    - package-install

  - name: install dependencies
    # XXX Determine what RH repository this will belong to so that it can be
    # properly checked and errored if the repository is not enabled.
    yum:
      name: rhscon-agent
      state: present
    when: ansible_os_family == 'RedHat'
    tags:
      - package-install

Expected results:
  It should behave similarly on Ubuntu same as on RHEL (install and configure the same or equivalent packages).

Comment 2 Ken Dreyer (Red Hat) 2016-06-20 13:37:15 UTC
Good catch Daniel. The package is named "rhscon-agent" on both RHEL and Ubuntu.

Comment 3 Alfredo Deza 2016-06-20 13:41:22 UTC
Pull Request upstream: https://github.com/ceph/ceph-ansible/pull/853

Comment 10 Daniel Horák 2016-07-28 10:54:23 UTC
Tested on:
  ceph-ansible-1.0.5-31.el7scon.noarch
  ceph-installer-1.0.14-1.el7scon.noarch

All required packages are installed on Ubuntu nodes.

>> VERIFIED

Comment 12 errata-xmlrpc 2016-08-23 19:55:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.