Bug 1348138 - snapshot type not reported at all if Version: 3
Summary: snapshot type not reported at all if Version: 3
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.0.1
: 4.0.1.1
Assignee: Juan Hernández
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 09:18 UTC by Tomas Jelinek
Modified: 2016-08-04 13:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-04 13:30:25 UTC
oVirt Team: Infra
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
rule-engine: planning_ack+
juan.hernandez: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 59462 0 ovirt-engine-4.0 MERGED restapi: Populate V3 snapshot type correctly 2016-06-20 10:23:41 UTC
oVirt gerrit 59465 0 ovirt-engine-4.0 MERGED restapi: Populate V3 snapshot type correctly 2016-06-20 12:34:57 UTC

Description Tomas Jelinek 2016-06-20 09:18:15 UTC
On 3.x API (real 3.6 installation) the snapshot type has been reported as:
<snapshot>
        <type>active</type>
</snapshot>

On 4.x installation with "Version: 4" header it is reported as:
<snapshot>
        <snapshot_type>active</snapshot_type>
</snapshot>

On 4.x installation with "Version: 3" the type is not reported at all.

Expected results:
if on 4.0 installation the "Version: 3" is sent, the <snapshot><type>active</... is returned.

Comment 1 Red Hat Bugzilla Rules Engine 2016-06-20 09:18:20 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.

Comment 2 Red Hat Bugzilla Rules Engine 2016-06-20 09:48:51 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Oved Ourfali 2016-06-20 12:44:22 UTC
Moving to 4.0.1, as there is no re-spin planned.
No action item needed as the 4.0 patch is merged so will automatically be included in the 4.0.1 build.

Comment 4 Petr Matyáš 2016-07-27 07:14:56 UTC
Verified on 4.0.2-1


Note You need to log in before you can comment on or make changes to this bug.