Bug 134814 - Unable to compile IT8212F driver after upgrading to FC2.
Unable to compile IT8212F driver after upgrading to FC2.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel-utils (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 10:33 EDT by peter
Modified: 2015-01-04 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-29 17:41:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description peter 2004-10-06 10:33:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I upgraded from FC1 to FC2 using 4 CDs I had burnt.  I have a IT8212F
PCI card.  It supports extra IDE devices by emulating them to SCSI
devices.  With the kernel it needs to be recompiled but the
recompilation is failing.
I have downloaded the latest drivers from the vendor and I believe
they should work.

I had to errors.  The initial was I could not find autoconf.h.  The
compile refused to look at
/lib/modules/2.6.5-1.358/build/include/linux directories.  I kludged
this by copying the required files to
/usr/src/linux-2.6.5-1.358/include/ directories. 

The problem I am getting now is when I do a "make" I get this output :

[root@petershost ITERaid]# make
make -I/lib/modules/2.6.5-1.358/build/include/    -C
/usr/src/linux-2.6.x SUBDIRS=/usr/src/linux-2.6.x/ITERaid modules
make[1]: Entering directory `/usr/src/linux-2.6.5-1.358'
  CC [M]  /usr/src/linux-2.6.x/ITERaid/iteraid.o
In file included from /usr/src/linux-2.6.x/ITERaid/iteraid.c:266:
/usr/src/linux-2.6.x/ITERaid/iteraid.h:946: error: syntax error before
"Scsi_Cmnd"
/usr/src/linux-2.6.x/ITERaid/iteraid.h:946: warning: no semicolon at
end of struct or union
/usr/src/linux-2.6.x/ITERaid/iteraid.h:947: warning: type defaults to
`int' in declaration of `SCSI_REQUEST_BLOCK'
/usr/src/linux-2.6.x/ITERaid/iteraid.h:947: warning: type defaults to
`int' in declaration of `PSCSI_REQUEST_BLOCK'
/usr/src/linux-2.6.x/ITERaid/iteraid.h:947: warning: data definition
has no type or storage class
/usr/src/linux-2.6.x/ITERaid/iteraid.h:1201: error: syntax error
before "PSCSI_REQUEST_BLOCK"
/usr/src/linux-2.6.x/ITERaid/iteraid.h:1201: warning: no semicolon at
end of struct or union
/usr/src/linux-2.6.x/ITERaid/iteraid.h:1206: warning: type defaults to
`int' in declaration of `OriginalSrb'


I believe the error is
iteraid.h:946: error: syntax error before "Scsi_Cmnd"
and is being caused because I can't find the definition for
"Scsi_Cmnd".  When I look at /include/scsi I can find a definition for
 "scsi_cmnd" but not for "Scsi_Cmnd".  (I can find references to
Scsi_Cmnd but no definition).


Either I have screwed up somehow - definately possible, or there
something has change or something has been left out which is
preventing the compile from working.  I currently have 250G of data
that is unaccessible.




Thanks Zach.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358   kernel-source-2.6.5-1.358

How reproducible:
Always

Steps to Reproduce:
Run the make file.

    

Additional info:


rpm -qa | grep kernel 
kernel-2.6.5-1.358
kernel-source-2.6.5-1.358
kernel-utils-2.4-9.1.131
kernel-doc-2.6.5-1.358

(The reason I rated this as severe is because I have unavailable data
which seems to match the criteria).


Thanks Zach.
Comment 1 peter 2004-10-06 19:28:22 EDT
Hello ??

I have change my problem slightly now. If I do this
cp -a /usr/src/linux-2.6.x/drivers/scsi/scsi.h            .
cp -a /usr/src/linux-2.6.x/drivers/scsi/hosts.h           .
cp -a /usr/src/linux-2.6.x/drivers/scsi/scsi_obsolete.h   .
cp -a /usr/src/linux-2.6.x/drivers/scsi/scsi_typedefs.h   .

and change the source to '#include "scsi_typedefs.h" and "#include
"scsi_obselete.h"'  ie from the current directory then when I do a
make I only get -

iteraid.c: In function `itedev_open':
iteraid.c:5580: warning: `MOD_INC_USE_COUNT' is deprecated (declared
at /usr/src/ITERaid2/module.h:501)
iteraid.c: In function `itedev_close':
iteraid.c:5817: warning: `MOD_DEC_USE_COUNT' is deprecated (declared
at /usr/src/ITERaid2/module.h:513)
iteraid.c: At top level:
iteraid.c:4667: warning: `IdeMediaStatus' defined but not used

Thanks Zach.
Comment 2 Dave Jones 2004-10-29 17:41:31 EDT
this driver is intended for use with 2.6.1 (See the Makefile)

bug the vendor to update it (or better yet, try to work something out upstream).

Note You need to log in before you can comment on or make changes to this bug.