Bug 1348151 - Undercloud installation fails due to missing tripleo-common package
Summary: Undercloud installation fails due to missing tripleo-common package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: beta
: 10.0 (Newton)
Assignee: James Slagle
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 09:57 UTC by Marius Cornea
Modified: 2016-12-14 15:40 UTC (History)
7 users (show)

Fixed In Version: instack-undercloud-4.0.1-0.20160606104910.f7c7d30.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-14 15:40:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Marius Cornea 2016-06-20 09:57:50 UTC
Description of problem:
Undercloud installation fails due to missing tripleo-common package:

Error: Execution of '/bin/yum -d 0 -e 0 -y list tripleo-common' returned 1: Error: No matching Packages to list
Error: /Stage[main]/Main/Package[tripleo-common]/ensure: change from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y list tripleo-common' returned 1: Error: No matching Packages to list


Version-Release number of selected component (if applicable):
instack-undercloud-4.0.1-0.20160606104910.f7c7d30.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. openstack undercloud install

Actual results:
Fails:
Error: Execution of '/bin/yum -d 0 -e 0 -y list tripleo-common' returned 1: Error: No matching Packages to list
Error: /Stage[main]/Main/Package[tripleo-common]/ensure: change from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y list tripleo-common' returned 1: Error: No matching Packages to list

Expected results:
Installation completes.

Additional info:
I can see that there is a package called openstack-tripleo-common.noarch available for installation.

Comment 2 Marius Cornea 2016-06-20 10:11:01 UTC
Workaround:

s/tripleo-common/openstack-tripleo-common in:

/usr/share/instack-undercloud/undercloud-install/os-refresh-config/post-configure.d/98-undercloud-setup
/usr/share/instack-undercloud/puppet-stack-config/puppet-stack-config.pp

Comment 3 Jon Schlueter 2016-06-21 19:36:28 UTC
Cherry-picked upstream patch Change-Id: I4246a874941c9f97e7c5b3775298948e3df16313 from upstream which resolves this issue.  Next tag will include this patch as well

Comment 5 Alexander Chuzhoy 2016-09-16 16:38:53 UTC
Verified:
Environment:
instack-undercloud-5.0.0-0.20160818065636.41ef775.el7ost.noarch

Was able to deploy undercloud without reproducing the reported issue.

Comment 8 errata-xmlrpc 2016-12-14 15:40:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.