Bug 1348166 - 2.0: /api/v2/cluster/<fs-id>/server does not display fqdn correctly
Summary: 2.0: /api/v2/cluster/<fs-id>/server does not display fqdn correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 2.0
Assignee: Christina Meno
QA Contact: Harish NV Rao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 10:29 UTC by Harish NV Rao
Modified: 2016-08-23 19:42 UTC (History)
3 users (show)

Fixed In Version: RHEL: calamari-server-1.4.3-1.el7cp Ubuntu: calamari-server_1.4.3-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:42:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
/api/v2/cluster/<fs-id>/server does not display fqdn correctly (7.51 KB, text/plain)
2016-06-20 10:29 UTC, Harish NV Rao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 0 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Harish NV Rao 2016-06-20 10:29:15 UTC
Created attachment 1169829 [details]
/api/v2/cluster/<fs-id>/server does not display fqdn correctly

Description of problem:

 fqdn is displayed properly for the mon where calamari-lite is running. For rest of the nodes, it displays only host shortname. 

output of  /api/v2/cluster/<fsid>/server will be attached.

Tested on:
calamari-server-1.4.1-1.el7cp.x86_64
ceph version 10.2.2-1.el7cp

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 5 Christina Meno 2016-06-21 20:46:38 UTC
https://github.com/ceph/calamari/pull/470

Comment 10 errata-xmlrpc 2016-08-23 19:42:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.