Bug 134824 - up2date hangs when rhn_check runs?
up2date hangs when rhn_check runs?
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
Depends On:
  Show dependency treegraph
Reported: 2004-10-06 11:24 EDT by Thomas J. Baker
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-19 15:16:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-10-06 11:24:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041002

Description of problem:
In doing the rhel3u3 updates, I've had many systems hang during the
installation phase. No CPU activity, no disk activity, nothing. It
seemed clearly like a locking issue. I've just discovered on one
system that at precisely the time the up2date hung, rhn_check started
running and it hung too. I don't know if it's the cause or another
symptom. As a test I tried to just do an rpm -q and it hung too. There
was no way to recover. I had to kill -9 all rpm related processes and
remove the /var/lib/rpm/__* files. I'm left with many duplicate rpms
in the database which I have to now go through and remove the old
versions using the justdb switch. It's happened enough times for the
U3 update that I've got a script to recover from it. I know this is
not the most scientific bug report but it's not something easily
debugged and it's also not something I want to duplicate since I run
RHEL3 on my stable systems.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 15:16:52 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
For more information of the RHEL errata support policy, please visit:
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.