Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1348325 - Error importing manifest: Error code shows improper organization id
Summary: Error importing manifest: Error code shows improper organization id
Keywords:
Status: CLOSED DUPLICATE of bug 1343108
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Subscription Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 20:01 UTC by jcallaha
Modified: 2018-08-31 15:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-06-21 10:42:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
foreman debug (697.82 KB, application/x-xz)
2016-06-20 20:01 UTC, jcallaha
no flags Details
error (97.00 KB, image/png)
2016-06-20 20:08 UTC, jcallaha
no flags Details

Description jcallaha 2016-06-20 20:01:49 UTC
Created attachment 1169981 [details]
foreman debug

Description of problem:
When trying to import/refresh a manifest on a CI system, I am presented with the following errors.
Error importing manifest. Organization with id Ml9apa could not be found.
Error refreshing manifest. Organization with id Ml9apa could not be found.
This was on a CI machine and an Org with an id of 1810. Org name was 'jake' and no instance of 'Ml9apa' was associated with the Org in any way. However, there was an Org on the system with that name.

Version-Release number of selected component (if applicable):
Satellite 6.2 Beta Snap 16.

Steps to Reproduce:
I'm unsure how to reproduce, you can try creating an org and importing a manifest on a machine that has had our automation run on it (approx 1800 Orgs created).

Actual results:
These errors are shown when trying to import/refresh a manifest.
Error importing manifest. Organization with id Ml9apa could not be found.
Error refreshing manifest. Organization with id Ml9apa could not be found.

Expected results:
No errors are shown and the manifest is imported/refreshed correctly.

Comment 1 jcallaha 2016-06-20 20:08:44 UTC
Created attachment 1169983 [details]
error

Comment 3 Andrii Balakhtar 2016-06-21 10:42:02 UTC
I believe it's a side-effect of https://bugzilla.redhat.com/show_bug.cgi?id=1343108. Feel free to reopen in case i'm wrong (although i think i'm not, we're facing this issue on CI environment for a long period of time)

*** This bug has been marked as a duplicate of bug 1343108 ***


Note You need to log in before you can comment on or make changes to this bug.