Bug 1348334 - docker forces firewalld installation
Summary: docker forces firewalld installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: docker
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Antonio Murdaca
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-20 20:40 UTC by Jan Včelák
Modified: 2016-09-11 03:51 UTC (History)
13 users (show)

Fixed In Version: docker-1.10.3-21.git19b5791.fc24 docker-1.10.3-43.gita612434.fc23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-11 03:51:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Včelák 2016-06-20 20:40:01 UTC
Description of problem:

The updated docker package requires firewalld (as a fix for #1327809), however the minimal requirement for docker seems to be iptables.

For the sake of minimal installation, I suggest to make docker require just iptables (and recommend firewalld if you fancy weak-dependencies).

Version-Release number of selected component (if applicable):
2:1.10.3-19.gitee81b72.fc24

How reproducible:
always

Steps to Reproduce:
1. dnf update docker
2.
3.

Actual results:
Upgrading: docker, docker-selinux
Installing: firewalld, firewalld-filesystem, ipset, ipset-libs, python3-decorator, python3-firewall, python3-slip, python3-slip-dbus


Expected results:
Upgrading: docker, docker-selinux
Installing: (nothing)

Additional info:

Comment 1 Antonio Murdaca 2016-06-20 21:16:41 UTC
That came from https://bugzilla.redhat.com/show_bug.cgi?id=1327809

I'll remove firewalld from f24 and f23

Comment 2 Antonio Murdaca 2016-06-20 21:36:50 UTC
seems like in f25 we just need iptables and not the whole firewalld also

Comment 3 Fedora Update System 2016-06-20 21:49:59 UTC
docker-1.10.3-33.gitee81b72.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e849d66f7d

Comment 4 Fedora Update System 2016-06-20 21:53:05 UTC
docker-1.10.3-20.gitee81b72.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2bf24eaa11

Comment 5 Fedora Update System 2016-06-22 02:27:08 UTC
docker-1.10.3-20.gitee81b72.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2bf24eaa11

Comment 6 Fedora Update System 2016-06-22 02:55:10 UTC
docker-1.10.3-33.gitee81b72.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e849d66f7d

Comment 7 Jan Včelák 2016-06-23 10:00:11 UTC
Antonio, I'm not sure if the fix is correct.

The firewalld dependency disappeared, which is fine. But the iptables dependency was not added in the F24 package. (I can see it in git/master though, so I guess it will be fine for F25.)

% rpm -qp docker-1.10.3-20.gitee81b72.fc24.x86_64.rpm --requires | \
  grep iptables || echo 'no iptables'
no iptables

Comment 8 Antonio Murdaca 2016-06-23 10:03:08 UTC
(In reply to Jan Včelák from comment #7)
> Antonio, I'm not sure if the fix is correct.
> 
> The firewalld dependency disappeared, which is fine. But the iptables
> dependency was not added in the F24 package. (I can see it in git/master
> though, so I guess it will be fine for F25.)
> 
> % rpm -qp docker-1.10.3-20.gitee81b72.fc24.x86_64.rpm --requires | \
>   grep iptables || echo 'no iptables'
> no iptables

My understanding is that the iptables dep is only necessary in F25 because we don't have iptables 1.6 in F24 and it's not needed for Docker to have a dep on that because iptables comes with the base system.

Look here for background https://bugzilla.redhat.com/show_bug.cgi?id=1323161

Comment 9 Jan Včelák 2016-06-23 15:40:19 UTC
OK. Then it should be all right. Thanks.

Comment 10 Fedora Update System 2016-06-24 17:34:44 UTC
docker-1.10.3-21.git19b5791.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-492e781b1b

Comment 11 Fedora Update System 2016-06-24 18:11:11 UTC
docker-1.10.3-34.git19b5791.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7245efa28a

Comment 12 Fedora Update System 2016-06-26 00:27:16 UTC
docker-1.10.3-21.git19b5791.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-492e781b1b

Comment 13 Fedora Update System 2016-06-26 06:22:04 UTC
docker-1.10.3-34.git19b5791.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7245efa28a

Comment 14 Fedora Update System 2016-06-27 18:25:22 UTC
docker-1.10.3-21.git19b5791.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-07-01 19:59:26 UTC
docker-1.10.3-35.git3b3d748.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f221b26d2f

Comment 16 Fedora Update System 2016-07-02 20:53:56 UTC
docker-1.10.3-35.git3b3d748.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f221b26d2f

Comment 17 Fedora Update System 2016-07-06 14:52:54 UTC
docker-1.10.3-36.git971d3bf.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-73d248fd52

Comment 18 Fedora Update System 2016-07-10 03:54:35 UTC
docker-1.10.3-36.git971d3bf.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-73d248fd52

Comment 19 Fedora Update System 2016-07-12 20:17:07 UTC
docker-1.10.3-37.git29066b4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-47fac047d3

Comment 20 Fedora Update System 2016-07-14 01:24:13 UTC
docker-1.10.3-37.git29066b4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-47fac047d3

Comment 21 Fedora Update System 2016-07-20 21:32:29 UTC
docker-1.10.3-38.gitcba0656.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7bf2cb1e9b

Comment 22 Fedora Update System 2016-07-21 15:26:03 UTC
docker-1.10.3-39.git1ecb834.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0218df61cf

Comment 23 Fedora Update System 2016-07-21 18:48:06 UTC
docker-1.10.3-39.git1ecb834.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0218df61cf

Comment 24 Fedora Update System 2016-08-22 15:10:04 UTC
docker-1.10.3-40.git128f146.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a080364c5

Comment 25 Fedora Update System 2016-08-23 16:20:43 UTC
docker-1.10.3-40.git128f146.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a080364c5

Comment 26 Fedora Update System 2016-08-24 10:58:58 UTC
docker-1.10.3-41.git78aa320.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2d2e7b09c

Comment 27 Fedora Update System 2016-08-25 10:28:41 UTC
docker-1.10.3-41.git78aa320.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2d2e7b09c

Comment 28 Fedora Update System 2016-08-29 09:26:49 UTC
docker-1.10.3-42.gitc7e7694.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ae3ca3f0a

Comment 29 Fedora Update System 2016-08-29 22:52:58 UTC
docker-1.10.3-42.gitc7e7694.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9ae3ca3f0a

Comment 30 Fedora Update System 2016-09-02 09:00:57 UTC
docker-1.10.3-43.gita612434.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8686e64e55

Comment 31 Fedora Update System 2016-09-03 03:52:55 UTC
docker-1.10.3-43.gita612434.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8686e64e55

Comment 32 Fedora Update System 2016-09-11 03:51:17 UTC
docker-1.10.3-43.gita612434.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.