Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1348391 - certbot complains it is old
Summary: certbot complains it is old
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: certbot
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: James Hogarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1354198 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-21 05:45 UTC by Pierre Ossman
Modified: 2016-07-21 21:47 UTC (History)
7 users (show)

Fixed In Version: certbot-0.8.1-2.fc24 certbot-0.8.1-2.fc23 certbot-0.8.1-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 15:04:29 UTC
Type: Bug


Attachments (Terms of Use)
Remove deprecation warning (624 bytes, patch)
2016-06-24 10:28 UTC, Julien Enselme
no flags Details | Diff

Description Pierre Ossman 2016-06-21 05:45:46 UTC
I'm getting this when using certbot:

2016-06-21 06:10:41,322:WARNING:certbot.cli:You are running with an old copy of certbot that does not receive updates, and is less reliable than more recent versions. We recommend upgrading to the latest certbot-auto script, or using native OS packages.

Which isn't true as I'm running the latest (0.8.1).

Looking at the code it seems like it will complain like this whenever you're not running certbot-auto. Perhaps some patch is needed when it is being packaged as part of a distribution?

Comment 1 Julien Enselme 2016-06-24 10:20:56 UTC
Same message here on fedora 24. Crontab is spamming me. Is there a way to make a patch to prevent this?

Comment 2 Julien Enselme 2016-06-24 10:28:00 UTC
Created attachment 1171906 [details]
Remove deprecation warning

Can be applied with patch -p1 < certbot-remove-deprecation-warning.patch

Comment 3 Alan Hamilton 2016-07-01 16:13:17 UTC
I believe the issue is that the Fedora packaged version has auto-updates disabled (so it will be updated by new RPMs instead) but still has the warning enabled.

You can also silence the warning by creating /etc/letsencrypt/cli.ini with the contents

no-self-upgrade = True

or by passing --no-self-upgrade on the command line.

Comment 4 Robert Buchholz 2016-07-06 13:29:17 UTC
This message is not indented to be seen when calling "certbot" and is a downstream bug introduced by a string replace when building the package. New packages underway.

Comment 5 Fedora Update System 2016-07-07 08:54:21 UTC
certbot-0.8.1-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6ddadbf97f

Comment 6 Fedora Update System 2016-07-07 08:54:30 UTC
certbot-0.8.1-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-9204365431

Comment 7 Fedora Update System 2016-07-07 08:54:37 UTC
certbot-0.8.1-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-999186afcf

Comment 8 Robert Buchholz 2016-07-07 09:03:02 UTC
Please test the updates and report karma.

Comment 9 Fedora Update System 2016-07-10 03:18:42 UTC
certbot-0.8.1-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-999186afcf

Comment 10 Fedora Update System 2016-07-10 03:53:48 UTC
certbot-0.8.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9204365431

Comment 11 Fedora Update System 2016-07-10 15:59:53 UTC
certbot-0.8.1-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6ddadbf97f

Comment 12 Robert Buchholz 2016-07-10 22:25:48 UTC
*** Bug 1354198 has been marked as a duplicate of this bug. ***

Comment 13 Fedora Update System 2016-07-12 15:04:25 UTC
certbot-0.8.1-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2016-07-18 20:52:57 UTC
certbot-0.8.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2016-07-21 21:47:04 UTC
certbot-0.8.1-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.