Bug 1348431 - Openstack-gnocchi-statsd fails to start; ImportError: Your rados python module does not support omap feature. Install 'cradox' (recommended) or upgrade 'python-rados' >= 9.1.0
Summary: Openstack-gnocchi-statsd fails to start; ImportError: Your rados python modul...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-cradox
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: beta
: 10.0 (Newton)
Assignee: Jon Schlueter
QA Contact: Pradeep Kilambi
URL:
Whiteboard:
Depends On: 1344447
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-21 07:28 UTC by Marius Cornea
Modified: 2016-12-14 15:40 UTC (History)
12 users (show)

Fixed In Version: python-cradox-1.1.8-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1344447
Environment:
Last Closed: 2016-12-14 15:40:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description Marius Cornea 2016-06-21 07:28:29 UTC
Description of problem:
Openstack-gnocchi-statsd fails to start; ImportError: Your rados python module does not support omap feature. Install 'cradox' (recommended) or upgrade 'python-rados' >= 9.1.0

Version-Release number of selected component (if applicable):
python-gnocchi-2.1.1-0.20160608165716.0bbf079.el7ost.noarch
openstack-gnocchi-api-2.1.1-0.20160608165716.0bbf079.el7ost.noarch
openstack-gnocchi-carbonara-2.1.1-0.20160608165716.0bbf079.el7ost.noarch
puppet-gnocchi-8.0-0.20160608140922.d826734.el7ost.noarch
openstack-gnocchi-indexer-sqlalchemy-2.1.1-0.20160608165716.0bbf079.el7ost.noarch
openstack-gnocchi-statsd-2.1.1-0.20160608165716.0bbf079.el7ost.noarch
openstack-gnocchi-common-2.1.1-0.20160608165716.0bbf079.el7ost.noarch
openstack-gnocchi-metricd-2.1.1-0.20160608165716.0bbf079.el7ost.noarch
python-gnocchiclient-2.3.2-0.20160602183805.982b1ef.el7ost.noarch


How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud 
2. Check openstack gnocchi services

Actual results:
In /var/log/gnocchi/statsd.log:
ERROR gnocchi ImportError: Your rados python module does not support omap feature. Install 'cradox' (recommended) or upgrade 'python-rados' >= 9.1.0

Expected results:
Gnocchi services get started.

Comment 5 errata-xmlrpc 2016-12-14 15:40:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.