Bug 1348559 - Can not create quota limits via REST(V4)
Summary: Can not create quota limits via REST(V4)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.0.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-4.0.1
: 4.0.1.1
Assignee: Juan Hernández
QA Contact: Artyom
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-21 12:46 UTC by Artyom
Modified: 2016-07-19 06:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-19 06:25:15 UTC
oVirt Team: SLA
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
rule-engine: planning_ack+
juan.hernandez: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 59555 0 master MERGED restapi: Fix adding of quota storage limits 2016-06-22 07:52:44 UTC
oVirt gerrit 59597 0 ovirt-engine-4.0 MERGED restapi: Fix adding of quota storage limits 2016-06-22 10:15:38 UTC

Description Artyom 2016-06-21 12:46:02 UTC
Description of problem:
Can not create quota limits via REST

Version-Release number of selected component (if applicable):
rhevm-4.0.0.4-0.1.el7ev.noarch
ovirt-engine-restapi-4.0.0.4-0.1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create quota
2. Create storage limit under quota:
<quota_storage_limit>
  <limit>10</limit>
</quota_storage_limit>
3.

Actual results:
405 Method Not Allowed

Expected results:
Quota limit created

Additional info:
The same correct for cluster quota limit

Comment 1 Red Hat Bugzilla Rules Engine 2016-06-21 14:09:00 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 2 Artyom 2016-07-17 12:47:56 UTC
Verified on rhevm-4.0.2-0.2.rc1.el7ev.noarch

Comment 3 Sandro Bonazzola 2016-07-19 06:25:15 UTC
Since the problem described in this bug report should be
resolved in oVirt 4.0.1 released on July 19th 2016, it has been closed with a
resolution of CURRENT RELEASE.

For information on the release, and how to update to this release, follow the link below.

If the solution does not work for you, open a new bug report.

http://www.ovirt.org/release/4.0.1/


Note You need to log in before you can comment on or make changes to this bug.