Bug 1348582 - Installing rh-maven33-scldevel installs entire collection
Summary: Installing rh-maven33-scldevel installs entire collection
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: rh-maven35
Version: rh-maven35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: alpha
: 3.0
Assignee: Mikolaj Izdebski
QA Contact: Jan Kepler
URL:
Whiteboard:
Depends On:
Blocks: 1448496
TreeView+ depends on / blocked
 
Reported: 2016-06-21 13:43 UTC by Severin Gehwolf
Modified: 2017-10-24 09:53 UTC (History)
2 users (show)

Fixed In Version: rh-maven35-1-1.1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-24 09:53:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3022 0 normal SHIPPED_LIVE new packages: rh-maven35 2017-10-24 13:25:34 UTC

Description Severin Gehwolf 2016-06-21 13:43:11 UTC
Description of problem:
When rh-maven33-scldevel gets installed (e.g. to get access to scl_prefix_maven macro) the entire rh-maven33 collection seems to get installed as well.

Version-Release number of selected component (if applicable):
rh-maven33-scldevel-1-17.el7

How reproducible:
100%

Steps to Reproduce:
1. $ yum install rh-maven33-scldevel

Actual results:
All, or most?, rh-maven33 packages get installed. This includes maven itself and xmvn.

Expected results:
rh-maven33-scldevel and perhaps rh-maven33-runtime gets installed, but not the entire collection.

Additional info:
It's probably caused by this:

%package scldevel
Summary:    Package shipping development files for %scl
Requires:   %{name}-maven-local = %{version}-%{release} <<< Why?

Comment 6 errata-xmlrpc 2017-10-24 09:53:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3022


Note You need to log in before you can comment on or make changes to this bug.