Bug 134860 - mkswap -L not documented (-h and man-page)
mkswap -L not documented (-h and man-page)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 16:01 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 14:17:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-10-06 16:01:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040929

Description of problem:
mkswap now supports -L to set a label on the swap device, and anaconda
actually makes use of that, creating entries in /etc/fstab that
reference SWAP-$partition for a swap device in /dev/$partition. 
Unfortunately, if you happen to re-create the swap device for whatever
reason, swapon -a will no longer work because you don't have the
label, and neither mkswap -h nor man mkswpa will hint you to the
option to create the swap device correctly.  The new (?) -L option
ought to be mentioned in the -h output, as well as in the man-page.

Version-Release number of selected component (if applicable):
util-linux-2.12a-10

How reproducible:
Always

Steps to Reproduce:
1.mkswap -h
2.man mkswap

Actual Results:  No reference to -L label.

Expected Results:  Should be there.

Additional info:

One could always edit /etc/fstab after re-creating the swap
partitions, and live on without -L, but that sort of defeats the point.
Comment 1 Elliot Lee 2004-12-03 14:17:34 EST
Patch is in CVS.

Note You need to log in before you can comment on or make changes to this bug.