Bug 1348603 - bad events severity
Summary: bad events severity
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: UI
Version: 2
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ---
: 2
Assignee: Karnan
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks: Console-2-DevFreeze
TreeView+ depends on / blocked
 
Reported: 2016-06-21 14:43 UTC by Lubos Trilety
Modified: 2016-08-23 19:55 UTC (History)
4 users (show)

Fixed In Version: rhscon-core-0.0.34-1.el7scon.x86_64 rhscon-ceph-0.0.33-1.el7scon.x86_64 rhscon-ui-0.0.47-1.el7scon.noarch
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:55:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
events list (67.20 KB, image/png)
2016-06-21 14:43 UTC, Lubos Trilety
no flags Details
warning event (54.82 KB, image/png)
2016-06-21 14:44 UTC, Lubos Trilety
no flags Details
major event (56.66 KB, image/png)
2016-06-21 14:45 UTC, Lubos Trilety
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1341637 None None None Never
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Internal Links: 1341637

Description Lubos Trilety 2016-06-21 14:43:55 UTC
Created attachment 1170306 [details]
events list

Description of problem:
Some events have bad status icon in their details page.
E.g.
Events with major severity has warning status icon - ficon-warning-triangle-o. Events with warning severity don't have any status icon.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.24-1.el7scon.x86_64
rhscon-ui-0.0.39-1.el7scon.noarch
rhscon-ceph-0.0.23-1.el7scon.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create cluster
2. Stop some host with OSD role
3.

Actual results:
Two host related alerts are generated, one major about that host is down, one warning about the osd is down. First have warning status on the details page and the second has no status icon.

Expected results:
Correct status icon is displayed on details page the same as in the list.

Additional info:

Comment 1 Lubos Trilety 2016-06-21 14:44:55 UTC
Created attachment 1170308 [details]
warning event

details page of event with warning severity

Comment 2 Lubos Trilety 2016-06-21 14:45:32 UTC
Created attachment 1170309 [details]
major event

details page of event with major severity

Comment 4 Lubos Trilety 2016-07-22 10:58:29 UTC
Tested on:
rhscon-core-0.0.34-1.el7scon.x86_64
rhscon-ui-0.0.48-1.el7scon.noarch
rhscon-core-selinux-0.0.34-1.el7scon.noarch
rhscon-ceph-0.0.33-1.el7scon.x86_64

Major and warning events have correct icon on their details page.

Comment 6 errata-xmlrpc 2016-08-23 19:55:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.