Bug 1348646 - [RFE][TestOnly] - certify Ceph iSCSI target support with RHV
Summary: [RFE][TestOnly] - certify Ceph iSCSI target support with RHV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.2.0
: ---
Assignee: Mike Christie
QA Contact: Elad
URL:
Whiteboard:
Depends On:
Blocks: 1527061
TreeView+ depends on / blocked
 
Reported: 2016-06-21 16:15 UTC by Mike Christie
Modified: 2021-05-01 16:42 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1527061 (view as bug list)
Environment:
Last Closed: 2018-05-15 17:38:32 UTC
oVirt Team: External
Target Upstream Version:
ratamir: testing_plan_complete+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3610111 0 None None None 2020-12-08 15:30:30 UTC
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:40:08 UTC

Description Mike Christie 2016-06-21 16:15:02 UTC
Description of problem:

This RFE is for supporting Ceph's iSCSI Target in RHEV.

Ceph iSCSI support is being added to RHEL 7.3 in these bugzillas.

https://bugzilla.redhat.com/show_bug.cgi?id=1196117
https://bugzilla.redhat.com/show_bug.cgi?id=1196119

We should have support that you can begin testing in early/mid July.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 Yaniv Lavi 2016-11-10 14:33:17 UTC
Moving back due to issues found in testing. Waiting for new builds to test.

Comment 16 Raz Tamir 2017-07-09 05:53:10 UTC
Moving back to NEW as this is not ready for testing

Comment 17 Allon Mureinik 2017-07-10 11:40:54 UTC
(In reply to Raz Tamir from comment #16)
> Moving back to NEW as this is not ready for testing

Can you indicate what we're waiting for (and hopefully block this BZ on it) so it's easier to track?

Comment 18 Raz Tamir 2017-07-25 08:52:02 UTC
It seems like there's some fix need to be pushed by Mike.

Mike, can you please elaborate why we are blocking here?

Comment 19 Mike Christie 2017-07-25 17:28:31 UTC
(In reply to Raz Tamir from comment #18)
> It seems like there's some fix need to be pushed by Mike.
> 
> Mike, can you please elaborate why we are blocking here?

We were waiting for some patches to get merged in the kernel. They are now merged, but the userspace fixes needed to go with them are not in RHCS 2.3.

I am trying to finish RHCS 3.0 development right now and that will have the fixes. We are hoping to be done next week.

Comment 20 Yaniv Lavi 2017-08-10 11:42:50 UTC
Any updates?

Comment 21 Elad 2017-11-23 09:50:50 UTC
Executed RHV storage smoke automation tests over a seutp with iSCSI domain that reside on Ceph iSCSI server. No issues were found.


iSCSI initiator configuration:
http://docs.ceph.com/docs/master/rbd/iscsi-initiator-linux/

iSCSI server configuration (installed on the Ceph cluster):
http://docs.ceph.com/docs/master/rbd/iscsi-target-cli/

** before the last step (disk map to the initiator), the disk creation is missing from the doc. It’s done as follows:

# gwcli
> cd /
> disks/ create pool=rbd size=10

Chap authentication:
/iscsi-target...age-ge2-vdsm3> auth chap=myserver/mypassword2016          



Used:

engine:
ovirt-engine-4.2.0-0.0.master.20171116212005.git61ffb5f.el7.centos.noarch

Hypervisor:
vdsm-4.20.7-1.gitc9cf1ee.el7.centos.x86_64
iscsi-initiator-utils-6.2.0.874-4.el7.x86_64
device-mapper-multipath-0.4.9-111.el7.x86_64


Storage:
targetcli-2.1.fb47-0.1.20170301.gitf632f38.el7cp.noarch
ceph-iscsi-cli-2.0-5.el7cp.noarch
python-cephfs-10.2.7-48.el7cp.x86_64
ceph-common-10.2.7-48.el7cp.x86_64
ceph-osd-10.2.7-48.el7cp.x86_64
ceph-iscsi-tools-2.0-3.el7cp.noarch
ceph-selinux-10.2.7-48.el7cp.x86_64
ceph-radosgw-10.2.7-48.el7cp.x86_64
libcephfs1-10.2.7-48.el7cp.x86_64
ceph-base-10.2.7-48.el7cp.x86_64
ceph-mon-10.2.7-48.el7cp.x86_64
ceph-iscsi-config-2.0-4.el7cp.noarch

Moving to VERIFIED

Comment 22 Yaniv Kaul 2017-11-23 09:54:16 UTC
The bug is for 4.1.z, not 4.2.0.
Can you repeat the tests on 4.1.z?

Comment 23 Elad 2017-11-24 16:38:45 UTC
Executed the same with 4.1 [1], no issues were found.
Jenkins execution will be provided offline in mail.

[1]
vdsm-4.19.38-1.el7ev.x86_64
ovirt-engine-4.1.8-0.1.el7.noarch

Comment 24 Yaniv Lavi 2017-12-18 12:18:53 UTC
Can you clone this bug to z stream?

Comment 31 errata-xmlrpc 2018-05-15 17:38:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 32 Franta Kust 2019-05-16 13:04:07 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.