Bug 1348860 - [Bug] RHEV-H unnecessarily requests for a RHEL license
Summary: [Bug] RHEV-H unnecessarily requests for a RHEL license
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor
Version: unspecified
Hardware: All
OS: Linux
medium
high
Target Milestone: ovirt-3.5.9
: ---
Assignee: Douglas Schilling Landgraf
QA Contact: cshao
URL:
Whiteboard:
Keywords: ZStream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-22 08:39 UTC by Adi Akbar
Modified: 2016-08-03 14:28 UTC (History)
9 users (show)

(edit)
Previously, during subscription of a Red Hat Enterprise Virtualization Hypervisor (RHEV-H) via Red Hat Subscription Manager, the non-required Red Hat Enterprise Linux repository was included. Now, only the RHEV channel is added during subscription.
Clone Of:
(edit)
Last Closed: 2016-08-03 14:28:45 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1557 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.5 2016-08-03 18:28:36 UTC
oVirt gerrit 60367 ovirt-3.5 MERGED ovirt-init-functions: remove rhel 69.pem 2016-07-07 16:37 UTC

Description Adi Akbar 2016-06-22 08:39:33 UTC
Description of problem:

Customer has set-up RHEV-H using the ISO. A RHEL hypervisor. When trying to register the hypervisor using RHSM, it gets registered and subscribed to the RHEV subscription but checking the status shows not subscribed for RHEL server. The question is: Why does the hypervisor look or expect a RHEL server subscription to be attached to it along with RHEV?


Version-Release number of selected component (if applicable): N/A


How reproducible:


Steps to Reproduce:

1. Set-up RHEV-H using ISO
2. Register using

                  # subscription-manager register
                  # subscription-manager attach --pool=<pool-of-RHEV-sub>


3. Check status using # subscription-manager list

[root@rhevtnt6 ~]# subscription-manager refresh
All local data refreshed
[root@rhevtnt6 ~]# subscription-manager list

+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Virtualization
Product ID:     150
Version:        3.4
Arch:           x86_64
Status:         Subscribed
Status Details:
Starts:         05/20/2016
Ends:           05/20/2017

Product Name:   Red Hat Enterprise Linux Server     <--
Product ID:     69
Version:        6.7
Arch:           x86_64
Status:         Not Subscribed                      <--
Status Details: Not supported by a valid subscription.   <--
Starts:
Ends:


Actual results:

+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Virtualization
Product ID:     150
Version:        3.4
Arch:           x86_64
Status:         Subscribed
Status Details:
Starts:         05/20/2016
Ends:           05/20/2017

Product Name:   Red Hat Enterprise Linux Server     <--
Product ID:     69
Version:        6.7
Arch:           x86_64
Status:         Not Subscribed                      <--
Status Details: Not supported by a valid subscription.   <--
Starts:
Ends:


Expected results:

+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Virtualization
Product ID:     150
Version:        3.4
Arch:           x86_64
Status:         Subscribed
Status Details:
Starts:         05/20/2016
Ends:           05/20/2017

Additional info: 

/etc/pki/product only contains the pem for RHEV and not for RHEL. Why is the system looking for a RHEL subscription?

Comment 1 Fabian Deutsch 2016-06-22 15:59:19 UTC
This is a bug. RHEV-H should not request a RHEL license.

The product certificate needs to be removed from RHEV-H.

Comment 2 Douglas Schilling Landgraf 2016-07-07 02:09:57 UTC
Hi Adi,

In the RHEV-H, it's not required the pool option which might be affecting the system. It's not required because the RHEV-H is read only system, no additional packages can be installed without a real upgrade. Could customer register via TUI? 

Vritant, could it be an issue in subscriber-manager?

Comment 3 Douglas Schilling Landgraf 2016-07-07 02:12:26 UTC
(In reply to Douglas Schilling Landgraf from comment #2)
> Hi Adi,
> 
> In the RHEV-H, it's not required the pool option which might be affecting
> the system. It's not required because the RHEV-H is read only system, no
> additional packages can be installed without a real upgrade. Could customer
> register via TUI? 
> 
> Vritant, could it be an issue in subscriber-manager?

Hi, please ignore this initial comment, I pressed enter too early. The 69.pem is shipped with the 3.5 rhev-h and should be removed from the build. No action from is required from support.

Comment 4 Douglas Schilling Landgraf 2016-07-07 02:15:47 UTC
Additionally information, in rhev-h 3.6 we don't have such issue.

Comment 5 cshao 2016-07-28 09:56:06 UTC
Test version:
redhat-virtualization-host-4.0-20160727.1 
imgbased-0.7.3-0.1.el7ev.noarch

Test steps:
1. Anaconda install RHVH via PXE.
2. Register using
                  # subscription-manager register
                  # subscription-manager attach --pool=<pool-of-RHEV-sub>

3. Check status using # subscription-manager list

# subscription-manager refresh
All local data refreshed
# subscription-manager list


Test result:
The unnecessarily requests for a RHEL license was gone, so the bug is fixed, change bug status to VERIFIED.

Comment 8 errata-xmlrpc 2016-08-03 14:28:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1557.html


Note You need to log in before you can comment on or make changes to this bug.