Bug 134887 - NetworkManager needs to trim old Networks
NetworkManager needs to trim old Networks
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-06 19:50 EDT by Jonathan Blandford
Modified: 2013-04-02 00:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 08:46:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Blandford 2004-10-06 19:50:13 EDT
Currently, NetworkManager will keep older networks around in gconf. 
While not inherently harmful, it would be nice to have a mechanism for
cleaning them out.  As a possibility, we could have a 'last used'
timestamp and remove ones after a certain time.  Needs some thought.
Comment 1 John Thacker 2006-10-29 16:56:46 EST
Changing version to correct version bug was filed against.  (Some were filed
against "test3" when they clearly are for FC3T2, a test for FC3.)
Comment 2 Matthias Clasen 2006-11-26 13:43:22 EST
There seems to be a timestamp for each network connection in gconf. 
Does NM use it to purge old connections ?
Comment 3 Dan Williams 2008-02-12 08:46:31 EST
NM doesn't purge connections, but latest 0.7 (F8 and rawhide) and 0.6.6 (will be
pushed to F7) have connection editors that allow you to manually remove old
wireless networks if you so desire.

Note You need to log in before you can comment on or make changes to this bug.