Bug 1348917 - Display problem with applications grouped by type (> 20 programs) in KDE4
Summary: Display problem with applications grouped by type (> 20 programs) in KDE4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-workspace
Version: 7.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1420851 1479818
TreeView+ depends on / blocked
 
Reported: 2016-06-22 10:11 UTC by amit yadav
Modified: 2018-10-26 07:58 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 11:31:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0717 None None None 2018-04-10 11:33:40 UTC
Red Hat Knowledge Base (Solution) 2388541 None None None 2016-06-22 10:24:05 UTC

Description amit yadav 2016-06-22 10:11:12 UTC
Description of problem:
When having multiple windows of the same type open (say xterm or konsole) and having KDE group them by type in the task bar, if you have more than 20 grouped, clicking on the taskbar button loads the list invisibly.  I cannot see the list of windows for that type but if I click where the list should be it opens a window.  Grouped list is invisible on the screen, I cannot see the list.

Version-Release number of selected component (if applicable):
kdeplasma-addons-4.10.5-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. On RHEL7.2, login into kde session and open more that 20 windows of konsole.
It will be grouped in one list.
2. Minimize all windows and click on grouped window to see the list.

Actual results:
I cannot see the list of windows for that type, but if I click where the list should be it opens a window.

Expected results:
I should be able to see the list of windows.

Additional info:
If I change the widget style from "System Settings -> Style -> Applications -> Widget Style" and click on grouped window list it shows the list correctly, only one time. But after that the same issue reappears.

Comment 4 Jan Grulich 2016-10-26 07:00:33 UTC
I have no update on this, but reading your description it looks it won't be hard to fix this.

Comment 9 Jan Grulich 2017-09-27 10:12:38 UTC
Fixed in kde-workspace-4.11.19-10.el7.

Comment 15 errata-xmlrpc 2018-04-10 11:31:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0717


Note You need to log in before you can comment on or make changes to this bug.