Bug 1348948 - IPA server install fails with build ipa-server-4.4.0-0.el7.1.alpha1
Summary: IPA server install fails with build ipa-server-4.4.0-0.el7.1.alpha1
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Keywords: Regression, TestBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-22 11:41 UTC by Kaleem
Modified: 2016-11-04 05:55 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:55:23 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Kaleem 2016-06-22 11:41:49 UTC
Description of problem:
IPA server install fails with latest 7.3 build ipa-server-4.4.0-0.el7.1.alpha1.x86_64

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-0.el7.1.alpha1.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install IPA 
2.
3.

Actual results:
Installation failed.

Expected results:
Installation should be successful

Additional info:

Comment 1 Petr Vobornik 2016-06-22 11:46:35 UTC
Culprit:

[root@idm ~]# journalctl -u httpd.service
-- Logs begin at Wed 2016-06-22 16:36:16 IST, end at Wed 2016-06-22 17:07:30 IST. --
Jun 22 16:46:18 idm.testrelm.test systemd[1]: Starting The Apache HTTP Server...
Jun 22 16:46:18 idm.testrelm.test httpd[19559]: AH00526: Syntax error on line 45 of /etc/httpd/conf.d/ipa.conf:
Jun 22 16:46:18 idm.testrelm.test httpd[19559]: Invalid option to WSGI daemon process definition.
Jun 22 16:46:18 idm.testrelm.test systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Jun 22 16:46:18 idm.testrelm.test kill[19561]: kill: cannot find process ""
Jun 22 16:46:18 idm.testrelm.test systemd[1]: httpd.service: control process exited, code=exited status=1
Jun 22 16:46:18 idm.testrelm.test systemd[1]: Failed to start The Apache HTTP Server.
Jun 22 16:46:18 idm.testrelm.test systemd[1]: Unit httpd.service entered failed state.
Jun 22 16:46:18 idm.testrelm.test systemd[1]: httpd.service failed.
Jun 22 17:01:30 idm.testrelm.test systemd[1]: Starting The Apache HTTP Server...
Jun 22 17:01:30 idm.testrelm.test httpd[25759]: AH00526: Syntax error on line 45 of /etc/httpd/conf.d/ipa.conf:
Jun 22 17:01:30 idm.testrelm.test httpd[25759]: Invalid option to WSGI daemon process definition.
Jun 22 17:01:30 idm.testrelm.test systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Jun 22 17:01:30 idm.testrelm.test kill[25761]: kill: cannot find process ""
Jun 22 17:01:30 idm.testrelm.test systemd[1]: httpd.service: control process exited, code=exited status=1
Jun 22 17:01:30 idm.testrelm.test systemd[1]: Failed to start The Apache HTTP Server.
Jun 22 17:01:30 idm.testrelm.test systemd[1]: Unit httpd.service entered failed state.
Jun 22 17:01:30 idm.testrelm.test systemd[1]: httpd.service failed.

i.e.  socket-timeout=2147483647 in ipa.conf:

WSGIDaemonProcess ipa processes=2 threads=1 maximum-requests=500 \
 display-name=%{GROUP} socket-timeout=2147483647

Comment 5 Kaleem 2016-07-04 14:46:32 UTC
Verified.

IPA Server version:
===================
[root@dhcp207-129 ~]# rpm -q ipa-server
ipa-server-4.4.0-1.el7.x86_64
[root@dhcp207-129 ~]#

Comment 7 errata-xmlrpc 2016-11-04 05:55:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.