Bug 1348968 - Snapshot getting created on Slave Node
Summary: Snapshot getting created on Slave Node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Tanay Ganguly
Bara Ancincova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-22 12:22 UTC by Tanay Ganguly
Modified: 2017-07-30 15:29 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-10.2.2-22.el7cp Ubuntu: ceph_10.2.2-17redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Documented with BZ#1348928
Clone Of:
Environment:
Last Closed: 2016-08-23 19:42:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16411 None None None 2016-06-22 12:30:07 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Tanay Ganguly 2016-06-22 12:22:33 UTC
Description of problem:
While trying to create snapshot from Slave Node, 2/5 times it got created

Version-Release number of selected component (if applicable):
10.2.2-5.el7cp

How reproducible:
2 out of 5 times

Steps to Reproduce:
1. Tried to take snapshot on an already existing up+replaying image from Slave Node.

for i in {1..25}; do rbd snap create test/liver1@snappy$i --cluster slave; done

Actual results:
Snapshot is getting created on the Slave Node.

rbd -p test --image liver1 snap ls --cluster slave
120 snappy1 11111 MB

Expected results:
Snapshot should never get created on Slave Node.

Additional info:
This happened to me twice, mostly the 1st iteration is going through.

Comment 9 Tanay Ganguly 2016-07-25 09:08:32 UTC
Marking it Verified.

for i in {1..10}; do rbd snap create MIRROR/anfield$i@snappy$i --cluster ceph --debug-rbd=0; done
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system
rbd: failed to create snapshot: (30) Read-only file system


Did the same command 8-10 times.

Comment 11 errata-xmlrpc 2016-08-23 19:42:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.