Bug 1349016 - Wayland - super slow
Summary: Wayland - super slow
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ffwayland
TreeView+ depends on / blocked
 
Reported: 2016-06-22 13:55 UTC by Andreas Nilsson
Modified: 2017-06-26 10:01 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-06-26 10:01:05 UTC


Attachments (Terms of Use)

Description Andreas Nilsson 2016-06-22 13:55:38 UTC
Using the firefox-wayland copr.

It's super slow in general. Takes like 5 seconds to change focus.

Comment 1 Christian Stadelmann 2016-06-25 00:03:32 UTC
I think this issue is somewhat different: The UI always immediately reacts on input (e.g. clicking on a menu button), but it doesn't always update the window contents.

Immediately works:
* buttons causing popup/popover menus to open (sandwich menu, downloads menu, bookmarks button…)
* dialog or window controls e.g. profile manager
* Profile manager: selecting a profile from the list by double click
* everything inside popups/popver menus, e.g. inside bookmarks/downloads/sandwich menu

Don't work immediately but have a delay of ~5 seconds:
* scrolling
* opening, closing, switching tabs (note that the window title changes immediately though)
* clicking links
* Profile Manager: selecting a profile from the list by single click
* opening developer console by Ctrl+Shift+I
* showing/hiding menu by pressing Alt

In short it seems like everything in GUI element MozContainer will be repainted after a huge delay. Everything outside (e.g. popovers in subsurfaces, header bar, …) is painted immediately.

Comment 2 Christian Stadelmann 2016-06-25 00:33:51 UTC
Also, when moving the window, its content is immediately repainted.

Comment 3 srakitnican 2016-06-28 06:16:57 UTC
(In reply to Christian Stadelmann from comment #2)
> Also, when moving the window, its content is immediately repainted.

Having this issue as well. Under wayland window repainting doesn't work most of the time until window loses focus. When it works, it works only for a split of a second.

Comment 4 Christian Stadelmann 2017-06-01 20:44:29 UTC
I cannot reproduce this issue any more with firefox-wayland-55.6-1.fc26.x86_64 from Martin Stransky's firefox-wayland copr.

Comment 5 Martin Stransky 2017-06-26 10:01:05 UTC
Seems to be fixed now, Thanks.


Note You need to log in before you can comment on or make changes to this bug.