Bug 1349036 - ceph-ansible should explicitly require ansible < 2
Summary: ceph-ansible should explicitly require ansible < 2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 2
Assignee: Ken Dreyer (Red Hat)
QA Contact: Rachana Patel
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-22 14:47 UTC by Ken Dreyer (Red Hat)
Modified: 2016-08-23 19:55 UTC (History)
7 users (show)

Fixed In Version: ceph-ansible-1.0.5-23.el7scon ceph-installer-1.0.12-3.el7cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:55:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1754 normal SHIPPED_LIVE New packages: Red Hat Storage Console 2.0 2017-04-18 19:09:06 UTC

Description Ken Dreyer (Red Hat) 2016-06-22 14:47:37 UTC
Description of problem:
We have only tested ceph-ansible with Ansible 1.9 in the RHSCON repository. We should update the ceph-ansible package to explicitly require Ansible 1.9, so that if a customer has access to a newer Ansible RPM, it will not be upgraded.

Version-Release number of selected component (if applicable):
ceph-ansible-1.0.5-22.el7scon

How reproducible:
always

Steps to Reproduce:
1. Set up a RHEL 7 node
2. Activate EPEL
3. yum install ceph-ansible

Actual results:
Ansible 2 from EPEL is installed.

Expected results:
Ansible 1.9 is installed.

Comment 1 Ken Dreyer (Red Hat) 2016-06-22 15:22:48 UTC
Change submitted upstream: https://github.com/ceph/ceph-installer/pull/161

Comment 3 Ken Dreyer (Red Hat) 2016-06-22 16:28:38 UTC
It turns out EPEL was probably a poor example above, since EPEL ships its own "ansible19" package. But since EPEL is unsupported anyway, this is good enough, I think. The main goal is to avoid upgrading to Ansible 2 from another Red Hat product.

Comment 10 errata-xmlrpc 2016-08-23 19:55:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1754


Note You need to log in before you can comment on or make changes to this bug.