Bug 1349049 - User portal reports Internal error when taking a pool VM
Summary: User portal reports Internal error when taking a pool VM
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.6.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.0.1
: 4.0.1
Assignee: Shmuel Melamud
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks: 1350403
TreeView+ depends on / blocked
 
Reported: 2016-06-22 15:24 UTC by Roman Hodain
Modified: 2019-04-28 10:47 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, when the Manager tried to prestart a virtual machine from a virtual machine pool, it was possible that a user could try to run the same virtual machine at the same time. In this case, the User Portal displayed an 'Internal error' message. This issue was fixed and now it is not possible for a user to run the same virtual machine that is being prestarted by the Manager.
Clone Of:
: 1350403 (view as bug list)
Environment:
Last Closed: 2016-08-23 20:43:32 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1743 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0 GA Enhancement (ovirt-engine) 2016-09-02 21:54:01 UTC
oVirt gerrit 59795 master NEW core: Take VM lock before assigning a pooled VM to user 2016-06-26 19:52:40 UTC
oVirt gerrit 60018 None None None 2016-07-02 22:07:24 UTC
oVirt gerrit 60143 ovirt-engine-4.0.1 MERGED core: Take VM lock before assigning a pooled VM to user 2016-07-04 15:58:04 UTC

Description Roman Hodain 2016-06-22 15:24:24 UTC
Description of problem:
When a user tries to get a VM from the User portal, the user receives error

Your operation is concealed. 
There is an error virtual pool's virtual machine is running.
This is internal engine error.

Version-Release number of selected component (if applicable):
rhev 3.6.6

How reproducible:
Time to time (a race condition)

Steps to Reproduce:
1. Try to get a VM which is currently being prestarted.

Actual results:
The portal report an error

Expected results:
The user is provided with an available VM

Comment 7 Tal Nisan 2016-07-04 13:23:26 UTC
In order to be included in 4.0.1 a patch has to be posted and merged on 4.0.1 branch as well, please either post the patch or move to 4.0.2 and MODIFIED

Comment 8 meital avital 2016-08-11 16:13:42 UTC
Verified on version: 4.0.2.6-0.1.el7ev 

Verified steps:
1)Create VM pool with 3 prestart VMs
2)In the user portal-> try to run one of the VMs before the Engine try - succeeded

Comment 10 errata-xmlrpc 2016-08-23 20:43:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1743.html


Note You need to log in before you can comment on or make changes to this bug.