Bug 134907 - Mouse hangs in X, triggered by some activity in certain games
Mouse hangs in X, triggered by some activity in certain games
Status: CLOSED DUPLICATE of bug 132471
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 00:22 EDT by Kevin E. Glosser
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:06:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin E. Glosser 2004-10-07 00:22:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914
Firefox/0.10

Description of problem:
If I play Unreal Tournament 2004 or DOOM 3 after only a couple minutes
my mouse will stop working. Keyboard continues to work, but all mouse
activity is lost. If I exit the game, the mouse is not working in X
either.

I can get the mouse to start working again by switching to virtual
terminal 1 via ctrl-alt-f1 and then back to 7 via ctrl-alt-f7

I have been unable to make the mouse fail in any other way other than
playing these 2 games.

I have switched mice from the original Microsoft Intellimouse Explorer
to the newer Microsoft (version of the same thing but with only 3
buttons and wheel, 20 dollar version) and the error occured with both.

Both times using USB mice.

Dell Dimension 8300
P4 3.0 Ghz 800 Mhz FSB
1 Gb ddr 400 RAM
nvidia geforce 4 titanium (128 Mb)
soundblaster live 5.1
onboard ethernet

latest drivers from nvidia 6.111

latest patches for FC 2

This bug is reproduceable 100% of the time by launching either game
and playing for 1 to 5 minutes.

I believe issue is either with...
1) my X configuration
2) something USB related
3) perhaps a service i turned off?

Version-Release number of selected component (if applicable):
6.7.0-9

How reproducible:
Always

Steps to Reproduce:
1. launch X
2. launch either UT2004 or DOOM3
3. start a game , play for a couple minutes and the mouse stops working
    

Actual Results:  No mouse input accepted

Expected Results:  mouse should continue to work

Additional info:

Games dont seem to produce a error message.

Only error in boot log is mdmpd failing to load.
Comment 1 Kristian Høgsberg 2004-10-20 18:10:22 EDT

*** This bug has been marked as a duplicate of 132471 ***
Comment 3 Kristian Høgsberg 2004-11-24 14:06:02 EST
As reported in bug #132471, this problem went away when the PCs bios
was upgraded and PS2 mouse support disabled.
Comment 4 Red Hat Bugzilla 2006-02-21 14:06:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.