Bug 134909 - krb5-1.2.7-28 build from SRPM fails with gcc-3.3.3
krb5-1.2.7-28 build from SRPM fails with gcc-3.3.3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: krb5 (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 00:53 EDT by Sivasankar Chander
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 1.2.7-41
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-15 17:29:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patchfile for krb5-1.2.7-28 to allow building with gcc-3.3.3 (1.46 KB, patch)
2004-10-07 01:01 EDT, Sivasankar Chander
no flags Details | Diff

  None (edit)
Description Sivasankar Chander 2004-10-07 00:53:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040808

Description of problem:
Attempted to rebuild krb5-1.2.7-28.src.rpm using an (upgraded)
gcc-3.3.3 compiler toolchain, but the build failed to complete.




Version-Release number of selected component (if applicable):
krb5-1.2.7-28.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install gcc-3.3.3
2. Rebuild krb5-1.2.7-28.src.rpm

    

Actual Results: 
.
.
.
gcc -DKRB5_DNS_LOOKUP_KDC=1 -DKRB5_DNS_LOOKUP_REALM=1
-DKRB5_DNS_LOOKUP=1 -DSTDC_HEADERS=1 -DHAVE_STRING_H=1
-DHAVE_ARPA_NAMESER_H=1 -DHAVE_UNISTD_H=1 -DHAVE_SYS_SELECT_H=1
-DHAVE_STDLIB_H=1 -DHAVE_ARPA_INET_H=1 -DTERMCAP=1 -DUSE_TERMIO=1
-DPOSIX_SIGNALS=1 -DKRB4=1  -DAUTHENTICATION -DENCRYPTION -DKRB5
-DFORWARD -UNO_LOGIN_F -DLOGIN_CAP_F -DLOGIN_PROGRAM=KRB5_PATH_LOGIN
-DLINEMODE -DKLUDGELINEMODE -DDIAGNOSTICS -DENV_HACK -DOLD_ENVIRON
-DKRB5_KRB4_COMPAT -I../../../include -I./../../../include
-I../../../include/krb5 -I./../../../include/krb5 -I.. -I./.. -O2
-march=i386 -mcpu=i686 -D_FILE_OFFSET_BITS=64 -fPIC -c commands.c
In file included from commands.c:63:
/usr/lib/gcc-lib/i386-redhat-linux/3.3.3/include/varargs.h:4:2: #error
"GCC no longer implements <varargs.h>."
/usr/lib/gcc-lib/i386-redhat-linux/3.3.3/include/varargs.h:5:2: #error
"Revise your code to use <stdarg.h>."
.
.
.

Expected Results:  It should have built cleanly.

Additional info:

The problem seems to be that inclusion of <varargs.h> is no longer
supported in gcc-3.3.3, and has been replaced by <stdarg.h>.

The attached patch (mostly syntax-related) fixes this and allows a
clean build of krb5-1.2.7-28.src.rpm with gcc-3.3.3 (it should also
work with earlier releases of gcc).
Comment 1 Sivasankar Chander 2004-10-07 01:01:25 EDT
Created attachment 104881 [details]
Patchfile for krb5-1.2.7-28 to allow building with gcc-3.3.3

Added as last patch (#45) in specfile, but the order doesn't really matter - it
only touches one file: krb5-1.2.7/src/appl/telnet/telnet/commands.c
Comment 2 Nalin Dahyabhai 2005-09-15 17:29:53 EDT
Fixed for RHEL3 in 1.2.7-41.

Note You need to log in before you can comment on or make changes to this bug.