Bug 134911 - X windows do not start with std Raedon driver and even if vesa is chosen , i cannot Shutdown the Xwindows AND AD1980 does not work
X windows do not start with std Raedon driver and even if vesa is chosen , i ...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
2
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-07 01:23 EDT by Hrishi
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 02:09:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hrishi 2004-10-07 01:23:44 EDT
Description :
My Config

AMD ATHLON 64 2800+

512 MB DDR 400MHZ

Asus K8vx board  (VIA Kt800 ) having
onboard AD1980 sound ,VIA SATA controller

GPU : ASUS ATI Raedon 9200se AGP @ 8x with 128MB DDR

Monitor Samsung 753DFX

Installtion type :Fedora Core 2 (x86_64)


Problems :--

1. After installation , the grub is not loaded  and i had
to manually go  and configure (in rescue mode) to
start GRUB (on MBR)

2. X windows hangs ( despite Fedora recognise my card as
ATI Raedon  9200se), so i switched the xorg config  file
to use the vesa driver ,but after getting a ugly screen
Xwindows starts .

3. After starting Xwindows using vesa driver ,
i am unable to  get out of X windows as doing a logoff
the machine hangs (I wanted to back to text mode ,  i use
linux in INIT mode as "3" instead of 5)


4. Myonboard AD1980 is recognised as VIA AC97 audio,
but no sound plays .


Version-Release number of selected component (if applicable):


How reproducible:
Everytime
1.Start Xwindows by giving startx (using raedon driver)
2.machine hangs

1.Start Xwindows by giving startx (using VESA driver)
2. Try to come out of X windows , machine hangs

1.AD1980 do not play any sounf
    Actual results:


Expected results:
Xwindows to work properly (display and sound)

Additional info:
Comment 1 Mike A. Harris 2004-10-12 02:09:04 EDT
This bug is invalid because it contains 4 individual bugs being
reported all in one bug report.  Please file individual bug reports
for each individual issue, and we can investigate them individually.

Fedora Core 2 ships with Xorg X11 (xorg-x11), and not XFree86,
so when filing your new bug report for the X server/driver issue,
please be sure to file it against the "xorg-x11" component.

Thanks in advance.

Note You need to log in before you can comment on or make changes to this bug.