Bug 1349180 - Including the nework-isolation.yaml file after network-management.yaml disables the Management network.
Summary: Including the nework-isolation.yaml file after network-management.yaml disabl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Dan Sneddon
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-22 21:46 UTC by Dan Sneddon
Modified: 2016-08-16 04:29 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-heat-templates-2.0.0-28.el7ost
Doc Type: Bug Fix
Doc Text:
The default newtork-isolation.yaml file contained values that conflicted with default network-management.yaml file in the director's Heat templates. If you included the network-isolation.yaml file after the network-management.yaml when creating an Overcloud, the deployment deactivates the Management network. This update refactors these files to avoid conflicts. Now the deployment processes both the network-management.yaml and network-isolationl.yaml in any order without conflict.
Clone Of:
Environment:
Last Closed: 2016-08-11 11:33:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1599 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 director Release Candidate Advisory 2016-08-11 15:25:37 UTC
OpenStack gerrit 341146 None None None 2016-07-29 19:05:34 UTC
Launchpad 1602283 None None None 2016-07-12 14:20:12 UTC

Description Dan Sneddon 2016-06-22 21:46:50 UTC
Description of problem:
If both network-management.yaml and newtork-isolation.yaml are included in the deployment command-line, and the network-isolation.yaml file is included later, then it overrides the management network, causing the Control Plane IP to appear where the Management IP should.

Version-Release number of selected component (if applicable):
OSP-Director 8.0

How reproducible:
100%

Steps to Reproduce:
1. openstack overcloud deploy --templates -e /path/to/network-management.yaml -e /path/to/network-isolation.yaml


Actual results:
The first file enables the Management network, and the second disables it.

Expected results:
The management network should be enabled.

Additional info:
Since the Management nework is disabled by default, there is no reason to include it in the network-isolation.yaml file.

Comment 1 Dan Sneddon 2016-06-23 17:44:06 UTC
Fix submitted upstream: https://review.openstack.org/#/c/333048

Comment 3 Thierry Vignaud 2016-07-11 13:04:16 UTC
This still hasn't landed in the stable/mitaka branch as far as I know.
Could you backport it?

Comment 4 Dan Sneddon 2016-07-11 13:19:03 UTC
(In reply to Thierry Vignaud from comment #3)
> This still hasn't landed in the stable/mitaka branch as far as I know.
> Could you backport it?

This patch will be backported to stable/mitaka once it has been merged in master. We don't do backports before the originating patch is merged, because it causes issues when we backport and then the original patch is revised.

Comment 5 Dan Sneddon 2016-07-12 19:22:01 UTC
This patch was merged to tripleo-heat-templates today, so I created a backport to stable/mitaka here:
https://review.openstack.org/#/c/341146/

Comment 8 Jaromir Coufal 2016-08-02 13:17:55 UTC
Already acked.

Comment 12 errata-xmlrpc 2016-08-11 11:33:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1599.html


Note You need to log in before you can comment on or make changes to this bug.