Bug 1349247 - [doc] Document dnf grouplist hidden
Summary: [doc] Document dnf grouplist hidden
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 25
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Documentation, EasyFix, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 04:10 UTC by Rahul Sundaram
Modified: 2017-02-10 16:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-10 16:02:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rahul Sundaram 2016-06-23 04:10:41 UTC
Description of problem:

dnf grouplist hidden works but it appears undocumented.  Please add a note to the man page.

Comment 1 Fedora Admin XMLRPC Client 2016-07-08 09:25:07 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Jan Kurik 2016-07-26 05:02:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 3 fednuc 2016-08-29 22:20:59 UTC
Also present in F24.

An example of why this would be useful:

I wanted to install the virtualisation group on a headless server, but baulked when I saw all of the X/Wayland libs it wanted to pull in, so ended up manually installing the items of the group excluding virt-manager/virt-viewer.

I subsequently discovered accidentally (via Anaconda software selection screen) that there is a hidden virtualization-headless group.

This is completely undiscoverable post-installation at present since the "hidden" group option is not in dnf's man page.

Comment 4 Abhijeet Kasurde 2016-12-12 14:33:21 UTC
PR available at https://github.com/rpm-software-management/dnf/pull/684

Comment 5 Jaroslav Mracek 2017-02-10 16:02:22 UTC
Bugs fixed in version of dnf-2.0.1-1.


Note You need to log in before you can comment on or make changes to this bug.