Bug 134925 - RedHat Installer and IBM x455 with USB Keyborad
Summary: RedHat Installer and IBM x455 with USB Keyborad
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: ia64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-10-07 10:11 UTC by Erhan Ekici
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 14:20:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Erhan Ekici 2004-10-07 10:11:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040928 Firefox/0.9.3

Description of problem:
I try to install RedHat Enterprise Linux AS 3 Update 3(ia64) on a IBM
x455 (88553RX) machine.

I use a USB Keyboard and USB Mouse because no PS/2 input on x455.

in EFI Diagnostic Menu, 

I tested these options : 

Test USB Functionality 
Test USB Keyboard 
Test USB Mouse

USB Func. test is OK.
USB Keyboard test is OK.

when I changed the one of the test options(I choose PnP test : NO)
and USB mouse test is Ok. 

I look at devices at EFI shell and results are:

Shell : devices -b

........
......  
88  B  _  _    1  2  1 Generic USB Mouse
89  B  _  _    1  3  1 Generic USB Keyboard
8A  B  _  _    1  2  1 Generic UsB Mouse
........
.....


Shell : devtree -b
.........
..........
  Ctrl [88]  Generic USB Mouse
	Ctrl [26] Primary Console Input Devices
  Ctrl [89]  Generic USB Keyboard
	Ctrl [26] Primary Console Input Devices
  Ctrl [8A]  Generic USB Mouse
	Ctrl [26] Primary Console Input Devices
.........
..........
........


Then, I choose CDROM from EFI Shell and elilo starts :

I typed linux text and pressed ENTER.(USB Keyboard was working properly) 
Installation started. But anymore USB mouse and USB Keyboard were not
working.

Anaconda was unable to detect my USB keyboard and USB Mouse. 

I didn't install RedHat Linux AS 3.0 on x455


Version-Release number of selected component (if applicable):
RHEL 3 Update 3 (ia64) 

How reproducible:
Always

Steps to Reproduce:
1. Connect USB Mouse and USB Keyb to x455
2. Insert RHEL AS 3 CD
3. Open EFI Shell and Start Installation
    

Actual Results:  Same result, no success

Additional info:

Comment 1 Erhan Ekici 2004-10-07 13:13:52 UTC
Additionaly, I used A4 Logitech USB mouse and Microsoft Wheel USB
mouse, but no change in result.

Erhan Ekici
  

Comment 2 Erhan Ekici 2004-10-08 14:09:49 UTC
The problem was solved. The solution is to use IBM USB Keyboard.

Erhan Ekici

Comment 3 Rik van Riel 2004-10-08 14:20:22 UTC
Thank you for confirming it was a hardware problem.


Note You need to log in before you can comment on or make changes to this bug.