Bug 1349281 - Fix `Conflicts` with ipa-python
Summary: Fix `Conflicts` with ipa-python
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 06:57 UTC by Jan Cholasta
Modified: 2016-11-04 05:55 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:55:27 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Jan Cholasta 2016-06-23 06:57:44 UTC
Description of problem:

Currently, we have the following Conflicts line in ipa-common and python-ipalib:

  Conflicts: %{name}-python < %{version}-%{release}

But rpmdiff does not like it:

  changed from Conflicts: ipa-python < 4.4.0-0.el7.1.alpha1 to Conflicts: ipa-python < 4.4.0-0.el7.2.alpha1 on noarch

To fix this, the conflicting version should be changed to < 4.2.91, i.e. to before ipa-python was split into ipa-common and python-ipalib.


Version-Release number of selected component (if applicable):
ipa-4.4.0-0.el7.2.alpha1

How reproducible:
Always.

Steps to Reproduce:
1.
2.
3.

Actual results:
rpmdiff complains

Expected results:
rpmdiff does not complain

Additional info:

Comment 1 Petr Vobornik 2016-06-28 07:38:22 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6004

Comment 2 Martin Bašti 2016-06-30 13:46:15 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/669da991837267435a6e6563794f93c2f207c80b

Comment 6 Abhijeet Kasurde 2016-09-15 05:57:16 UTC
Verified using IPA server version::
ipa-server-4.4.0-11.el7.x86_64

[root@ipamaster1 /]# rpm -q --conflicts ipa-common 
ipa-python < 4.2.91
freeipa-common
freeipa-python < 4.4.0
[root@ipamaster1 /]# rpm -q --conflicts python2-ipalib 
ipa-python < 4.2.91
freeipa-python < 4.4.0
[root@ipamaster1 /]# rpm -q ipa-server
ipa-server-4.4.0-11.el7.x86_64

Comment 8 errata-xmlrpc 2016-11-04 05:55:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.