Bug 1349314 - Dnf autoremove removes kernel-modules-extra but dnf update reinstalls those kernel modules again.
Summary: Dnf autoremove removes kernel-modules-extra but dnf update reinstalls those ...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 25
Hardware: x86_64 Linux
low
low
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 08:27 UTC by smurfendrek123
Modified: 2017-04-12 14:53 UTC (History)
11 users (show)

Fixed In Version: dnf-2.3.0-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-12 14:53:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debugdata after running autoremove and update (11.54 MB, application/x-tar)
2016-06-27 23:21 UTC, smurfendrek123
no flags Details

Description smurfendrek123 2016-06-23 08:27:53 UTC
Description of problem:
When i run dnf autoremove, it removes  kernel-modules-extra version 4.5.7-300.fc24.

When i run autoremove the exact same kernel modules get reinstalled again.

Version-Release number of selected component (if applicable): 1.1.9


How reproducible:
On my machine, it happens every time.


Steps to Reproduce:
1. Run sudo dnf autoremove
2. Run sudo dnf update

Actual results:
It removes kernel-modules-extra while it probably shouldn't

Expected results:
It shouldn't remove kernel-modules-extra

Additional info:
This is on a fresh install of fedora 24

Comment 1 smurfendrek123 2016-06-23 14:29:11 UTC
In the description the second autoremove should be dnf update, sorry.

Comment 2 Igor Gnatenko 2016-06-27 11:34:41 UTC
Please run dnf autoremove with --debugsolver and attach debugdata directory and also then run dnf update with --debugsolver and also attach debugdata.

Comment 3 Jaroslav Mracek 2016-06-27 11:41:32 UTC
Please, can you provide additional information about:
What packages were in autoremove transaction?
What packages were in upgrade transaction?
If after upgrade the `dnf autoremove` command is run, remove it again kernel-modules-extra ?

Thank you very much for additional information.

Comment 4 smurfendrek123 2016-06-27 23:21 UTC
Created attachment 1173196 [details]
Debugdata after running autoremove and update

I don't know if this is proper, if you need more, just ask.

Comment 5 smurfendrek123 2016-06-27 23:24:08 UTC
Jaroslav, the only package in both autoremove and update is: 

kernel-modules-extra      x86_64      4.5.7-300.fc24       @updates      2.1 M


If i run dnf autoremove after running dnf update, it still tries to remove the kernel modules extra, it's an endless cycle of autoremove and update.

Comment 6 Michael Schröder 2016-06-29 09:55:15 UTC
Dnf doesn't mark kernel-modules-extra-4.5.7-300 as userinstalled when it updates the kernel-modules-extra-4.5.5-300 package (which is userinstalled).

I seem to remember a fix in dnf or hawkey that makes it propagate the userinstalled flag on update, so maybe this is already solved. Or it does not work with multiinstall packages.

Comment 7 Honza Silhan 2016-07-04 11:10:38 UTC
We will investigate. Thanks Michael for the hint.

Comment 8 Fedora Admin XMLRPC Client 2016-07-08 09:31:11 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 9 smurfendrek123 2016-10-17 16:20:24 UTC
Hello, i'm sorry if this is innapropriate, but this is marked as easyfix, but it's still not fixed. How come?

Comment 10 Benjamin Xiao 2016-11-02 08:36:03 UTC
Still seeing this behavior on Fedora 24 with latest updates.

Comment 11 secondary 2016-12-04 17:55:49 UTC
Now on F25.

Comment 12 Sherif Omar 2016-12-05 18:08:04 UTC
Now on F25.

Comment 13 Jaroslav Mracek 2017-01-12 14:28:40 UTC
Please can you try dnf-2.0 from our test repository (sudo dnf copr enable rpmsoftwaremanagement/dnf-nightly)? Thanks a lot

Comment 14 Igor Gnatenko 2017-01-12 15:01:06 UTC
btw, I can reproduce this on my tablet on F25.

Comment 15 smurfendrek123 2017-01-26 00:35:44 UTC
Currently this doesn't happen anymore on f25 with dnf 1.1.

My currently installed kernels are: (output of rpm -qa kernel

kernel-4.9.4-201.fc25.x86_64
kernel-4.9.3-200.fc25.x86_64
kernel-4.9.5-200.fc25.x86_64

Comment 16 Jaroslav Mracek 2017-01-27 19:55:28 UTC
Please can you Igor investigate the issue, try it to reproduce with DNF 2.0 and provide as much as possible information to make it fixable.

Comment 17 Marco Kundt 2017-02-10 19:33:44 UTC
I do have the same problem with the kernel-modules package. Right now it's kernel-modules-4.9.8-201.fc25.x86_64. On 4.9.7 i used `sudo dnf mark userinstalled kernel-modules` which i thought to be a general mark, and not pinned to the version.

dnf-version: 1.1.10-5.fc25

Comment 18 Jaroslav Mracek 2017-03-30 16:37:14 UTC
I create patch that should fix the problem: https://github.com/rpm-software-management/dnf/pull/775

Comment 19 Fedora Update System 2017-04-10 08:02:13 UTC
dnf-2.3.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-80f2c2bb64

Comment 20 Fedora Update System 2017-04-11 00:25:58 UTC
dnf-2.3.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-80f2c2bb64

Comment 21 Fedora Update System 2017-04-12 14:53:20 UTC
dnf-2.3.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.