Bug 134934 - RITICAL **: file eggdesktopentries.c: line 2222 (egg_desktop_entries_add_group): assertion `group_name != NULL' failed
RITICAL **: file eggdesktopentries.c: line 2222 (egg_desktop_entries_add_grou...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-07 08:01 EDT by James Laska
Modified: 2013-09-02 02:01 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.0.4-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-18 14:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2004-10-07 08:01:50 EDT
# TREE rawhide-20041007
# ARCH i386

when yum updating, many %scriptlets are issuing an eggdesktopentries.c
assertion.  One such example is file-roller.  In its %scripts it
executes update-desktop-database, which in turn emits an assertion.

$ update-desktop-database /usr/share/applications

** (process:11751): CRITICAL **: file eggdesktopentries.c: line 2222
(egg_desktop_entries_add_group): assertion `group_name != NULL' failed

** (process:11751): CRITICAL **: file eggdesktopentries.c: line 2222
(egg_desktop_entries_add_group): assertion `group_name != NULL' failed

** (process:11751): CRITICAL **: file eggdesktopentries.c: line 2222
(egg_desktop_entries_add_group): assertion `group_name != NULL' failed
Comment 1 Miloslav Trmač 2004-10-18 14:27:22 EDT
desktop-file-utils-1.0.4-4 show a "nice" error message instead
of the above, also identifying the invalid .desktop file.
Comment 2 Miloslav Trmač 2004-10-18 14:28:45 EDT
desktop-file-utils-0.9-2. Sorry.
Comment 3 Mark Koljack 2005-04-20 00:30:30 EDT
I have no idea if I should open another bugzilla report or not.  My isssue is
the same as this.  My yum update output looks like this today:

Dependencies Resolved
Transaction Listing:
  Update: firefox.i386 0:1.0.3-1.3.1 - updates
  Update: htdig.i386 3:3.2.0b6-3.FC3.1 - updates
  Update: htdig-web.i386 3:3.2.0b6-3.FC3.1 - updates
  Update: urw-fonts.noarch 0:2.3-0.FC3.1 - updates
Total download size: 14 M
Is this ok [y/N]: y
Downloading Packages:
(1/4): htdig-web-3.2.0b6- 100% |=========================| 412 kB    00:01
(2/4): htdig-3.2.0b6-3.FC 100% |=========================| 942 kB    00:03
(3/4): firefox-1.0.3-1.3. 100% |=========================| 8.1 MB    00:19
(4/4): urw-fonts-2.3-0.FC 100% |=========================| 4.5 MB    00:13
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating: htdig 100 % done 1/8
Updating: htdig-web 100 % done 2/8
Updating: firefox 100 % done 3/8

** (process:7343): CRITICAL **: file eggdesktopentries.c: line 2232
(egg_desktop_entries_add_group): assertion `egg_desktop_entries_lookup_group
(entries, group_name) == NULL' failed
Updating: urw-fonts 100 % done 4/8
Completing update for htdig-web  - 5/8
Completing update for htdig  - 6/8
Completing update for firefox  - 7/8

** (process:7388): CRITICAL **: file eggdesktopentries.c: line 2232
(egg_desktop_entries_add_group): assertion `egg_desktop_entries_lookup_group
(entries, group_name) == NULL' failed
Completing update for urw-fonts  - 8/8

Updated: firefox.i386 0:1.0.3-1.3.1 htdig.i386 3:3.2.0b6-3.FC3.1 htdig-web.i386
3:3.2.0b6-3.FC3.1 urw-fonts.noarch 0:2.3-0.FC3.1
Complete!
_________________________________________________________________

I ran this command as root

$ update-desktop-database /usr/share/applications

This is the output:

[root@juancassie mkoljack]# update-desktop-database /usr/share/applications

** (process:19491): CRITICAL **: file eggdesktopentries.c: line 2232
(egg_desktop_entries_add_group): assertion `egg_desktop_entries_lookup_group
(entries, group_name) == NULL' failed
[root@juancassie mkoljack]#

I am unable to print at this point.  Please let me know what I should do?

Thank you -- Mark Koljack
Comment 4 Mark Koljack 2005-04-20 00:42:08 EDT
I forgot to add myself to the cc list.  Sorry.
Comment 5 Sergio Monteiro Basto 2005-09-12 17:48:24 EDT
update-desktop-database /usr/share/applications -v

Shows where is the error :
** (process:13332): CRITICAL **: egg_desktop_entries_add_group: assertion
`egg_desktop_entries_lookup_group (entries, group_name) == NULL' failed
File '/usr/share/applications/kde/kdmtheme.desktop' lacks MimeType key

Note You need to log in before you can comment on or make changes to this bug.