Bug 1349378 - [abrt] gnome-software: build_no_results_label(): gnome-software killed by SIGABRT
Summary: [abrt] gnome-software: build_no_results_label(): gnome-software killed by SIG...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 25
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:3e5b833ae83559638196a2b6efd...
Keywords:
: 1374527 1380138 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 10:58 UTC by iliketurtlesbro
Modified: 2016-11-30 05:29 UTC (History)
22 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-30 05:29:26 UTC


Attachments (Terms of Use)
File: backtrace (36.65 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: cgroup (242 bytes, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: core_backtrace (4.11 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: dso_list (17.14 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: environ (1.44 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: limits (1.29 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: maps (83.82 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: mountinfo (3.50 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: namespaces (102 bytes, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: open_fds (2.45 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: proc_pid_status (1.25 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details
File: var_log_messages (3.44 KB, text/plain)
2016-06-23 10:58 UTC, iliketurtlesbro
no flags Details

Description iliketurtlesbro 2016-06-23 10:58:09 UTC
Description of problem:
GNOME Notification told me that a program is requesting additional media codecs, clicked on the notification to open Software Center and find the appropriate package(s), and Software Center quickly crashed.

Version-Release number of selected component:
gnome-software-3.21.2-2.fc25

Additional info:
reporter:       libreport-2.7.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: build_no_results_label
executable:     /usr/bin/gnome-software
global_pid:     1436
kernel:         4.7.0-0.rc4.git1.1.fc25.x86_64
pkg_vendor:     Fedora Project
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (7 frames)
 #4 build_no_results_label at gs-shell-extras.c:444
 #5 show_search_results at gs-shell-extras.c:494
 #6 get_search_what_provides_cb at gs-shell-extras.c:658
 #7 g_task_return_now at gtask.c:1108
 #8 complete_in_idle_cb at gtask.c:1122
 #12 g_main_context_iteration at gmain.c:3912
 #13 g_application_run at gapplication.c:2381

Comment 1 iliketurtlesbro 2016-06-23 10:58:12 UTC
Created attachment 1171415 [details]
File: backtrace

Comment 2 iliketurtlesbro 2016-06-23 10:58:13 UTC
Created attachment 1171416 [details]
File: cgroup

Comment 3 iliketurtlesbro 2016-06-23 10:58:14 UTC
Created attachment 1171417 [details]
File: core_backtrace

Comment 4 iliketurtlesbro 2016-06-23 10:58:15 UTC
Created attachment 1171418 [details]
File: dso_list

Comment 5 iliketurtlesbro 2016-06-23 10:58:16 UTC
Created attachment 1171419 [details]
File: environ

Comment 6 iliketurtlesbro 2016-06-23 10:58:17 UTC
Created attachment 1171420 [details]
File: limits

Comment 7 iliketurtlesbro 2016-06-23 10:58:18 UTC
Created attachment 1171421 [details]
File: maps

Comment 8 iliketurtlesbro 2016-06-23 10:58:19 UTC
Created attachment 1171422 [details]
File: mountinfo

Comment 9 iliketurtlesbro 2016-06-23 10:58:20 UTC
Created attachment 1171423 [details]
File: namespaces

Comment 10 iliketurtlesbro 2016-06-23 10:58:21 UTC
Created attachment 1171424 [details]
File: open_fds

Comment 11 iliketurtlesbro 2016-06-23 10:58:22 UTC
Created attachment 1171425 [details]
File: proc_pid_status

Comment 12 iliketurtlesbro 2016-06-23 10:58:23 UTC
Created attachment 1171426 [details]
File: var_log_messages

Comment 13 Zdenek Chmelar 2016-07-24 13:48:02 UTC
Similar problem has been detected:

Gnome Software initiated searching of  a codec for video I wanted to launch in gnome-video.
Gnome Software crashed few seconds right after this search started.

reporter:       libreport-2.7.2
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: build_no_results_label
executable:     /usr/bin/gnome-software
global_pid:     1352
kernel:         4.7.0-0.rc7.git4.1.fc25.x86_64
package:        gnome-software-3.21.4-1.fc25
pkg_vendor:     Fedora Project
reason:         gnome-software killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Jan Kurik 2016-07-26 04:59:19 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 15 Ricardo Ramos 2016-09-11 17:15:27 UTC
Similar problem has been detected:

I was trying to install a codec to play an apple movie trailer insided totem.

reporter:       libreport-2.7.2
backtrace_rating: 3
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: build_no_results_label
executable:     /usr/bin/gnome-software
global_pid:     2031
kernel:         4.8.0-0.rc2.git3.1.fc25.x86_64
package:        gnome-software-3.21.4-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-software killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 16 Mikhail 2016-09-25 16:26:44 UTC
Similar problem has been detected:

try install HP printer

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: build_no_results_label
executable:     /usr/bin/gnome-software
global_pid:     1464
kernel:         4.8.0-0.rc7.git0.1.fc25.x86_64
package:        gnome-software-3.22.0-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-software killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 17 Christian Stadelmann 2016-09-28 13:25:10 UTC
Steps to reproduce (actually from https://bugzilla.gnome.org/show_bug.cgi?id=752285 which I tried to reproduce):

1. download or create a file with a mime type unknown to your gnome-software package database. On Fedora you can download a 3DMF file from http://www.artifice.com/3d_gallery/Maybeck_Studio-night.3dmf.sit
2. try to open this file (e.g. from nautilus). Now file-roller will try to open the file, displaying an error message:

Could not open this file type

There is no command installed for StuffIt archive files.
Do you want to search for a command to open this file?

[Cancel] [Search Command]

3. press [Search Command]. Now gnome-software will open a window which crashes after about 10 seconds.



Additional info:
I'm running gnome on wayland. 

Software versions in use:
gnome-software-3.22.0-1.fc25.x86_64
glib2-2.50.0-1.fc25.x86_64
gtk3-3.22.0-1.fc25.x86_64
PackageKit-1.1.4-1.fc25.x86_64
libwayland-client-1.12.0-1.fc25.x86_64

Comment 18 Zdenek Chmelar 2016-10-27 15:40:19 UTC
Similar problem has been detected:

Gnome Software was initiated with Gnome Videos in order to get codec for movie. Then this crash happened.

reporter:       libreport-2.8.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: build_no_results_label
executable:     /usr/bin/gnome-software
global_pid:     1579
kernel:         4.8.4-301.fc25.x86_64
package:        gnome-software-3.22.1-1.fc25
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
reason:         gnome-software killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 19 Steve 2016-11-23 14:10:02 UTC
I have this issue with totem. Here is the output from totem form the beginning until the crash of gnome-software:

---
$ totem test.avi
** Message: Missing plugin: gstreamer|1.0|totem|MPEG-4 Video (Advanced Simple Profile) decoder|decoder-video/mpeg, mpegversion=(int)4, systemstream=(boolean)false, profile=(string)advanced-simple, level=(string)5 (MPEG-4 Video (Advanced Simple Profile) decoder)
** Message: Missing plugin: gstreamer|1.0|totem|MPEG-1 Layer 3 (MP3) decoder|decoder-audio/mpeg, mpegversion=(int)1, layer=(int)3 (MPEG-1 Layer 3 (MP3) decoder)
** Message: PackageKit: xid = 0
** Message: PackageKit: desktop_id = org.gnome.Totem.desktop
** Message: PackageKit: Codec nice name: MPEG-4 Video (Advanced Simple Profile) decoder
** Message: PackageKit: ignoring field named profile
** Message: PackageKit: ignoring field named level
** Message: PackageKit: field is: mpegversion, type: gint
** Message: PackageKit: field is: systemstream, type: gboolean
** Message: PackageKit: structure: gstreamer1(decoder-video/mpeg)(mpegversion=4)(systemstream=false)()(64bit)
** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder
** Message: PackageKit: field is: mpegversion, type: gint
** Message: PackageKit: field is: layer, type: gint
** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegversion=1)(layer=3)()(64bit)
** Message: Missing plugins installed. Updating plugin registry ...
** Message: Plugin registry updated, trying again.
---

Note: There are no plugins installed after all.

Comment 20 Joachim Frieben 2016-11-24 16:02:41 UTC
After having installed packages mpg123-1.23.8-3.fc25, mpg123-libs-1.23.8-3.fc25, mpg123-plugins-jack-1.23.8-3.fc25, and mpg123-plugins-portaudio-1.23.8-3.fc25 on a fully updated Fedora 25 box, running 'rhythmbox <some_music_file>.mp3' launches gnome-software which suggests to search for a suitable codec (why?). Shortly afterwards, gnome-software crashes.

Comment 21 Amit Shah 2016-11-25 09:05:12 UTC
(In reply to Joachim Frieben from comment #20)
> After having installed packages mpg123-1.23.8-3.fc25,
> mpg123-libs-1.23.8-3.fc25, mpg123-plugins-jack-1.23.8-3.fc25, and
> mpg123-plugins-portaudio-1.23.8-3.fc25 on a fully updated Fedora 25 box,
> running 'rhythmbox <some_music_file>.mp3' launches gnome-software which
> suggests to search for a suitable codec (why?). Shortly afterwards,
> gnome-software crashes.

You need gstreamer1-plugin-mpg123 for rhythmbox to play it. (the jack and pulseaudio packages aren't needed for playback via rhythmbox)

Comment 22 Kalev Lember 2016-11-26 10:40:19 UTC
Should be fixed in gnome-software-3.22.2-1.fc25

Comment 23 Kalev Lember 2016-11-26 10:48:33 UTC
*** Bug 1374527 has been marked as a duplicate of this bug. ***

Comment 24 Kalev Lember 2016-11-26 10:48:55 UTC
*** Bug 1380138 has been marked as a duplicate of this bug. ***

Comment 25 Fedora Update System 2016-11-26 10:50:52 UTC
aisleriot-3.22.1-1.fc25 baobab-3.22.1-1.fc25 epiphany-3.22.3-1.fc25 evolution-3.22.2-1.fc25 evolution-data-server-3.22.2-1.fc25 evolution-ews-3.22.2-1.fc25 file-roller-3.22.2-1.fc25 five-or-more-3.22.2-1.fc25 four-in-a-row-3.22.1-1.fc25 glib2-2.50.2-1.fc25 gnome-boxes-3.22.3-1.fc25 gnome-calculator-3.22.2-1.fc25 gnome-chess-3.22.2-1.fc25 gnome-color-manager-3.22.2-1.fc25 gnome-desktop3-3.22.2-1.fc25 gnome-disk-utility-3.22.1-1.fc25 gnome-klotski-3.22.1-1.fc25 gnome-maps-3.22.2-1.fc25 gnome-mines-3.22.2-1.fc25 gnome-music-3.22.2-1.fc25 gnome-nibbles-3.22.2.2-1.fc25 gnome-online-accounts-3.22.2-1.fc25 gnome-photos-3.22.2-1.fc25 gnome-power-manager-3.22.2-1.fc25 gnome-robots-3.22.1-1.fc25 gnome-session-3.22.2-1.fc25 gnome-shell-3.22.2-2.fc25 gnome-shell-extensions-3.22.2-1.fc25 gnome-software-3.22.2-1.fc25 gnome-sudoku-3.22.2-1.fc25 gnome-system-monitor-3.22.2-1.fc25 gspell-1.2.1-1.fc25 gtk-doc-1.25-2.fc25 gtk3-3.22.4-1.fc25 gtksourceview3-3.22.1-1.fc25 gucharmap-9.0.2-1.fc25 gupnp-tools-0.8.13-1.fc25 gvfs-1.30.2-1.fc25 libappstream-glib-0.6.5-1.fc25 libgdata-0.17.6-3.fc25 lightsoff-3.22.2-1.fc25 mutter-3.22.2-1.fc25 orca-3.22.2-1.fc25 polari-3.22.2-1.fc25 swell-foop-3.22.2-1.fc25 vala-0.34.3-1.fc25 webkitgtk4-2.14.2-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5522a26f9b

Comment 26 Steve 2016-11-26 16:01:21 UTC
(In reply to Kalev Lember from comment #22)
> Should be fixed in gnome-software-3.22.2-1.fc25

This bug is not really fixed in this version. Gnome-software will not crash but does not find the MP3 codex. The message from gnome-software is: 

Unable to Find Requested Software; Unfortunately, the MPEG-1 Layer 3 (MP3) decoder you were searching for could not be found. Please see this website for more information.

Totem says:
$ totem test.mp3 
** Message: Missing plugin: gstreamer|1.0|totem|MPEG-1 Layer 3 (MP3) decoder|decoder-audio/mpeg, mpegversion=(int)1, layer=(int)3 (MPEG-1 Layer 3 (MP3) decoder)
** Message: PackageKit: xid = 33554447
** Message: PackageKit: desktop_id = org.gnome.Totem.desktop
** Message: PackageKit: Codec nice name: MPEG-1 Layer 3 (MP3) decoder
** Message: PackageKit: field is: mpegversion, type: gint
** Message: PackageKit: field is: layer, type: gint
** Message: PackageKit: structure: gstreamer1(decoder-audio/mpeg)(mpegversion=1)(layer=3)()(64bit)
** Message: Missing plugins installed. Updating plugin registry ...
** Message: Plugin registry updated, trying again.

gnome-software-3.22.2-1.fc25.x86_64

Comment 27 Fedora Update System 2016-11-27 22:58:13 UTC
aisleriot-3.22.1-1.fc25, baobab-3.22.1-1.fc25, epiphany-3.22.3-1.fc25, evolution-3.22.2-1.fc25, evolution-data-server-3.22.2-1.fc25, evolution-ews-3.22.2-1.fc25, file-roller-3.22.2-1.fc25, five-or-more-3.22.2-1.fc25, four-in-a-row-3.22.1-1.fc25, glib2-2.50.2-1.fc25, gnome-boxes-3.22.3-1.fc25, gnome-calculator-3.22.2-1.fc25, gnome-chess-3.22.2-1.fc25, gnome-color-manager-3.22.2-1.fc25, gnome-desktop3-3.22.2-1.fc25, gnome-disk-utility-3.22.1-1.fc25, gnome-klotski-3.22.1-1.fc25, gnome-maps-3.22.2-1.fc25, gnome-mines-3.22.2-1.fc25, gnome-music-3.22.2-1.fc25, gnome-nibbles-3.22.2.2-1.fc25, gnome-online-accounts-3.22.2-1.fc25, gnome-photos-3.22.2-1.fc25, gnome-power-manager-3.22.2-1.fc25, gnome-robots-3.22.1-1.fc25, gnome-session-3.22.2-1.fc25, gnome-shell-3.22.2-2.fc25, gnome-shell-extensions-3.22.2-1.fc25, gnome-software-3.22.2-1.fc25, gnome-sudoku-3.22.2-1.fc25, gnome-system-monitor-3.22.2-1.fc25, gspell-1.2.1-1.fc25, gtk-doc-1.25-2.fc25, gtk3-3.22.4-1.fc25, gtksourceview3-3.22.1-1.fc25, gucharmap-9.0.2-1.fc25, gupnp-tools-0.8.13-1.fc25, gvfs-1.30.2-1.fc25, libappstream-glib-0.6.5-1.fc25, libgdata-0.17.6-3.fc25, lightsoff-3.22.2-1.fc25, mutter-3.22.2-1.fc25, orca-3.22.2-1.fc25, polari-3.22.2-1.fc25, swell-foop-3.22.2-1.fc25, vala-0.34.3-1.fc25, webkitgtk4-2.14.2-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5522a26f9b

Comment 28 Fedora Update System 2016-11-30 05:29:26 UTC
aisleriot-3.22.1-1.fc25, baobab-3.22.1-1.fc25, epiphany-3.22.3-1.fc25, evolution-3.22.2-1.fc25, evolution-data-server-3.22.2-1.fc25, evolution-ews-3.22.2-1.fc25, file-roller-3.22.2-1.fc25, five-or-more-3.22.2-1.fc25, four-in-a-row-3.22.1-1.fc25, glib2-2.50.2-1.fc25, gnome-boxes-3.22.3-1.fc25, gnome-calculator-3.22.2-1.fc25, gnome-chess-3.22.2-1.fc25, gnome-color-manager-3.22.2-1.fc25, gnome-desktop3-3.22.2-1.fc25, gnome-disk-utility-3.22.1-1.fc25, gnome-klotski-3.22.1-1.fc25, gnome-maps-3.22.2-1.fc25, gnome-mines-3.22.2-1.fc25, gnome-music-3.22.2-1.fc25, gnome-nibbles-3.22.2.2-1.fc25, gnome-online-accounts-3.22.2-1.fc25, gnome-photos-3.22.2-1.fc25, gnome-power-manager-3.22.2-1.fc25, gnome-robots-3.22.1-1.fc25, gnome-session-3.22.2-1.fc25, gnome-shell-3.22.2-2.fc25, gnome-shell-extensions-3.22.2-1.fc25, gnome-software-3.22.2-1.fc25, gnome-sudoku-3.22.2-1.fc25, gnome-system-monitor-3.22.2-1.fc25, gspell-1.2.1-1.fc25, gtk-doc-1.25-2.fc25, gtk3-3.22.4-1.fc25, gtksourceview3-3.22.1-1.fc25, gucharmap-9.0.2-1.fc25, gupnp-tools-0.8.13-1.fc25, gvfs-1.30.2-1.fc25, libappstream-glib-0.6.5-1.fc25, libgdata-0.17.6-3.fc25, lightsoff-3.22.2-1.fc25, mutter-3.22.2-1.fc25, orca-3.22.2-1.fc25, polari-3.22.2-1.fc25, swell-foop-3.22.2-1.fc25, vala-0.34.3-1.fc25, webkitgtk4-2.14.2-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.