Bug 1349402 - snap unprotect of a busy image results in split-brain
Summary: snap unprotect of a busy image results in split-brain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RBD
Version: 2.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Jason Dillaman
QA Contact: Tanay Ganguly
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 12:27 UTC by Tanay Ganguly
Modified: 2017-07-30 15:30 UTC (History)
4 users (show)

Fixed In Version: RHEL: ceph-10.2.2-9.el7cp Ubuntu: ceph_10.2.2-7redhat1xenial
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:42:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16445 None None None 2016-06-23 12:50:03 UTC
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Tanay Ganguly 2016-06-23 12:27:18 UTC
Description of problem:
Trying to unprotect snap from Master Node, leading to inconsistency in Slave Journal

Version-Release number of selected component (if applicable):
10.2.2-5

How reproducible:


Steps to Reproduce:
1. Try to unprotect a snap from Parent Node.
2. Seeing the Image status as: 
liver1:
global_id:   e3415007-fcd9-402f-8a44-ede6d886cb96
   state:       up+error
  description: failed to commit journal event
  last_update: 2016-06-23 12:13:03

On the Slave Node

Actual results:
Its getting a “Device or resource busy” error from the master cluster

Expected results:
It should be up+replaying or syncing

Additional info:

Comment 3 Jason Dillaman 2016-06-27 16:08:20 UTC
Merged in upstream master: https://github.com/ceph/ceph/pull/9895

Comment 6 Tanay Ganguly 2016-07-26 10:03:16 UTC
Marking this as Verified, as i am unable to reproduce it.

ceph version 10.2.2-27.el7cp

Comment 8 errata-xmlrpc 2016-08-23 19:42:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1755.html


Note You need to log in before you can comment on or make changes to this bug.