Bug 1349483 - Since update cannot obtain tenant inventory data from OpenStack ( NON RH OPENSTACK VERSION! )
Summary: Since update cannot obtain tenant inventory data from OpenStack ( NON RH OPEN...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.5.5
Assignee: Ladislav Smola
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On: 1349310
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 14:05 UTC by John Prause
Modified: 2016-07-26 15:35 UTC (History)
6 users (show)

Fixed In Version: 5.5.5.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1349310
Environment:
Last Closed: 2016-07-26 15:35:49 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1488 normal SHIPPED_LIVE CFME 5.5.5 bug fixes and enhancement update 2016-07-26 19:28:27 UTC

Comment 3 CFME Bot 2016-06-23 18:43:32 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=72a85e2bd193e12ebef71dbcc9d39e817c4ba5c6

commit 72a85e2bd193e12ebef71dbcc9d39e817c4ba5c6
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Thu Jun 23 11:17:42 2016 +0200
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Thu Jun 23 16:10:11 2016 +0200

    Handle gracefully a missing tenant relationship
    
    Handle gracefully a missing tenant relationship, missing
    relationship can be caused by seeing tenant id on Image, while
    not having rights to read the actual tenant.
    
    Clean backport of:
    https://github.com/ManageIQ/manageiq/pull/9378
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1349483

 app/models/ems_refresh/save_inventory.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 4 CFME Bot 2016-06-23 18:43:36 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2b1c4a7c01cf08df99891c151a161953c6ced22f

commit 2b1c4a7c01cf08df99891c151a161953c6ced22f
Merge: 994a935 72a85e2
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Thu Jun 23 14:38:25 2016 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Thu Jun 23 14:38:25 2016 -0400

    Merge branch 'bz1349483' into '5.5.z'
    
    Handle gracefully a missing tenant relationship
    
    Handle gracefully a missing tenant relationship, missing
    relationship can be caused by seeing tenant id on Image, while
    not having rights to read the actual tenant.
    
    Clean backport of:
    https://github.com/ManageIQ/manageiq/pull/9378
    
    Fixes BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1349483
    
    See merge request !989

 app/models/ems_refresh/save_inventory.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 7 errata-xmlrpc 2016-07-26 15:35:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1488.html


Note You need to log in before you can comment on or make changes to this bug.