Bug 1349501 - [kde][gtk3] Mouse wheel doesn't work in an LibreOffice application after upgrade from FC23 to FC24 with GDK_CORE_DEVICE_EVENTS=1 and auto-activation on mouse-over
Summary: [kde][gtk3] Mouse wheel doesn't work in an LibreOffice application after upgr...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-06-23 14:44 UTC by Ian Morgan
Modified: 2016-06-27 18:25 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-06-27 18:25:02 UTC


Attachments (Terms of Use)

Description Ian Morgan 2016-06-23 14:44:23 UTC
Description of problem:
In KDE(5), mouse wheel (vertical scroll) does not work in any LibreOffice application in Fedora 24, even though it still works fine in other applications.

Version-Release number of selected component (if applicable):
libreoffice-5.1.4.2-1.fc24.x86_64
gtk3-3.20.6-1.fc24.x86_64

How reproducible:

Steps to Reproduce:
1. Launch oowriter or oocalc with any document longer than one screen-full, and attempt to scroll with the mousewheel.
2.
3.

Actual results:
Mouse wheel does nothing

Expected results:
Mouse wheel should scroll the page.

Additional info:

Something led me to remember that long ago, I put in a fix to allow the mouse wheel to work properly in Firefox after it started using GTK3.
I set GDK_CORE_DEVICE_EVENTS=1 to fix firefox (allows the scrollwheel to work without having to click on the window first (even though the window is already active)), but it seems this fix breaks LibreOffice scrollwheel entirely, so there is no way to scroll the document with the scrollwheel.

If I remove the GDK_CORE_DEVICE_EVENTS environment variable, the LibreOffice works again, but suffers the same fate as Firefox in that the scrollwheel does not work until the window is clicked first (even though the window is already activated by mouse-over).

I also found that I can leave GDK_CORE_DEVICE_EVENTS=1, and set SAL_USE_VCLPLUGIN=gen to fix LibreOffice, but of course it's butt-ugly then using basic X11 toolkit.

I need the mouse wheel to work in all applications without having to click in an already-activated window first (defeating the whole point of window auto-activation on mouse-over).

Comment 1 Caolan McNamara 2016-06-23 16:20:50 UTC
GDK_CORE_DEVICE_EVENTS=1 presumably causes the initial trouble because LibreOffice's gtk3 impl expects smooth scrolling events which aren't generated in that case

Comment 2 Caolan McNamara 2016-06-23 16:42:57 UTC
Well, lets add back the support for non-smooth scrolling again and see how far that gets us

Comment 3 Ian Morgan 2016-06-25 14:13:25 UTC
Confirmed fixed in 5.1.4.2-3 build retrieved from https://kojipkgs.fedoraproject.org/packages/libreoffice/5.1.4.2/3.fc24/

Scrolling works again whether GDK_CORE_DEVICE_EVENTS=1 is set or not.

Will await official release via fedora-updates. Thank you.

Comment 4 Fedora Update System 2016-06-25 20:11:55 UTC
libreoffice-5.1.4.2-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2bf872a06

Comment 5 Fedora Update System 2016-06-26 19:26:12 UTC
libreoffice-5.1.4.2-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f2bf872a06

Comment 6 Kriton Kyrimis 2016-06-27 08:18:09 UTC
I haven't tried the new version, but the problem with the mouse wheel may actually lie elsewhere:

I encountered the problem in one of my two F24 computers. I compared the two and found that several libreoffice-* packages were missing on the computer with the problem. I installed all of them; the crucial one in this case is libreoffice-kde4, which integrates libreoffice with KDE. With the package installed, not only does the mouse wheel work, but I also get KDE style menus and widgets (as specified in System Settings->Application Style->Widget Style) instead of GTK style menus and widgets (as specified ins System Settings->Application Style->Gnome Application Style (GTK)).

Comment 7 Caolan McNamara 2016-06-27 08:34:41 UTC
yes, with -kde installed under kde you are using a different "vclplug", the issue addressed here is solely for the "gtk3" vclplug

Comment 8 Kriton Kyrimis 2016-06-27 08:42:10 UTC
The bug reporter mentioned that he was running libreoffice under KDE, so this might work for him, as well.

Comment 9 Fedora Update System 2016-06-27 18:24:47 UTC
libreoffice-5.1.4.2-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.